Unable to communicate using the SPI1 line on the Xavier AGX module

Hello, I am using the Xavier AGX module and need to interface the spi1 line. However, I am unable to send or receive data. What are the changes I would need to make in the source and what files would I need to modify. I am using L4T35.1.0

These is the spi@3210000 in my device tree node which corresponds to spi1

spi@3210000 {
compatible = “nvidia,tegra186-spi”;
reg = <0x00 0x3210000 0x00 0x10000>;
interrupts = <0x00 0x24 0x04>;
#address-cells = <0x01>;
#size-cells = <0x00>;
iommus = <0x02 0x20>;
dmas = <0x25 0x0f 0x25 0x0f>;
dma-names = “rx\0tx”;
spi-max-frequency = <0x3dfd240>;
nvidia,clk-parents = “pll_p\0clk_m”;
clocks = <0x04 0x87 0x04 0x66 0x04 0x0e>;
clock-names = “spi\0pll_p\0clk_m”;
resets = <0x04 0x5b>;
reset-names = “spi”;
status = “okay”;
phandle = <0x2f5>;

	prod-settings {

		prod_c_cs0 {
			prod = <0x04 0xfff 0x11>;

	spi@0 {
		compatible = "tegra-spidev";
		reg = <0x00>;
		spi-max-frequency = <0x1f78a40>;

		controller-data {
			nvidia,rx-clk-tap-delay = <0x11>;

	spi@1 {
		compatible = "tegra-spidev";
		reg = <0x01>;
		spi-max-frequency = <0x1f78a40>;

		controller-data {
			nvidia,rx-clk-tap-delay = <0x11>;

Hi anims,

Are you using the devkit or custom board for Xavier AGX?

Have you tried the loopback test for SPI interface?
and what’s your current Jetpack version in use?

Hi KevinFFF,

I’m using a custom board with the Xavier AGX module running L4T R35.1.0 and Jetpack 5.0.2. I haven’t tried the SPI loopback test.

Could you help to update to latest Jetpack5.1.1 (R35.3.1) and verify SPI loopback test first?

You may refer to following thread to SPI loopback test.
How to set gpio for spi? - #27 by DaneLLL

Ok thank you, I will try updating to the latest jetpack and let you know.

Is there any known bug with Jetpack 5.0.2, R35.1 that can cause this issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.