Unable to Compile - GPU Nvidia Tesla v100 32GB


I’m trying to compile Caffe, when I ran the cmake command … in Caffe’s build directory, it even introduced me that it could not detect the GPU.

After that, I ran the make -j “$ (nproc)” command and got the following error:

nvcc fatal: Unsupported gpu architecture ‘compute_20’

I’ve encountered other errors too, when I squeeze the nvidia-smi command it returns me the following:

Failed to initialize NVML: Driver / library version mismatch

I have 8 Nvidia Tesla V100 32Gb cards, I also looked at the nvidia-persistenced and what turned me on was the following:

Mar 18 13:48:00 ubuntu nvidia-persistenced [5838]: Failed to query NVIDIA devices. Please ensure that the NVIDIA device files (/ dev / nvidia *) exist, and that user has read and write permissions for those files. ( I have already checked the permissions of the files and apparently it is OK. )
Mar 18 13:48:00 ubuntu nvidia-persistenced [5838]: PID file unlocked.
Mar 18 13:48:00 ubuntu nvidia-persistenced [5837]: nvidia-persistenced failed to initialize. Check syslog for more details.
Mar 18 13:48:00 ubuntu kernel: NVRM: API mismatch: the client has the version 418.43, but
NVRM: this kernel module has version 418.39. Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

My operating system is:

Ubuntu 16.04.06
Cuda 10.1

Could someone give me a hand?