unable to create ad-hoc/mesh mode in jetson tx2

I’m trying to setup a mesh network on 3 TX2 boards. I currently have the most up to date JetPack 4.2 and L4t R32.

I would like to have multiple TX2’s mesh together. I’m having trouble getting this feature to work. After searching around a bit I found the forum post below:

https://devtalk.nvidia.com/default/topic/1024785/unable-to-create-ad-hoc-mode-in-jetson-tx2/

However, this post points to an old version of L4T and the newer versions of L4T do not note the mesh/ad-hoc issue. Is this still an issue? and If not how can I get this to work.

My use case is to use the TX2 for a swarm of robots.

Can I get an NVIDIA response to this?

Hi,

Sorry for late reply. This issue is flagged as will not fix because it is caused by firmware crash from Broadcom.

Thank you WayneWWW for the response.

Just for future info, it looks like we were able to get mesh networking to work on our TX2 boards late last night. The solution was to use B.A.T.M.A.N. https://www.open-mesh.org/projects/open-mesh/wiki

We’re still diving deeper to make sure it holds as a final solution but so far my techs say its holding up.

Hi, I’m also setting up B.A.T.M.A.N in TX2. Do you have any suggestions about using it in TX2? By the way, have you tested the Jetpack 4.3 with B.A.T.M.A.N?

I just talked to my tech guys and they said they were able to get BATMAN to work with the TX2 without issue. but as above we used Jetpack 4.2