Unable to create new Android projects in TADP 4.0r1 on VS2010

When I follow the instructions at http://docs.nvidia.com/gameworks/index.html#developertools/mobile/nsight_tegra_create_app.htm%3FTocPath%3DDeveloper%20Tools|Mobile%20Developer%20Tools|Nsight%20Tegra%2C%20Visual%20Studio%20Edition|Nsight%20Tegra%20Visual%20Studio%20Edition%202.1|_____8

having installed TADP 4.0r1 without reported errors on a 64 bit Windows 7 PC running Visual Studio 2010 (SP1) steps 1 to 4 work as documented but after entering a valid package name the Finish button remains ghosted and it is impossible to either enter or select anything in the Min Target box, which remains blank.

Consequently it is not possible to create any new projects.

I’ve tried uninstalling and reinstalling TADP, and retried with a suitable device (an original Shield) connected over USB, but it seems this makes no difference.

I’m trying this to try and work out why existing solutions don’t allow the projects inside them to be built, without having to work with all 122 projects in our default solution. It’s not something I’d need to do otherwise - but I feel the discrepancy between the docs and my experience is worth noting here.

I have the same issue. Did you ever find a solution? 4.0r2 here.

Hi, thanks for the report and the interest in our solution.
It would be great if you could try the latest version of https://developer.nvidia.com/AndroidWorks
or at least upgrade to the 3.1 release of Nsight Tegra Visual Studio Edition
https://developer.nvidia.com/nvidia-nsight-tegra?mkt_tok=3RkMMJWWfF9wsRolvKvJZKXonjHpfsX%2F7OUoWq%2B%2Bgokz2EFye%2BLIHETpodcMScBlNq%2BTFAwTG5toziV8R7HAKs1v3NsQXBXg
If the issue persist, please, attach the logs. Also a short screencast depicting issue reproduction would be very helpful.

Same issue here with the most recent Nvidia tools under VS 2015. The “Min Target” is simply not populated.

Guess that might be relevant: (from the Nsight Tegra.log)

2016-04-27 11:30:45.6786|INFO|Nvidia.PentaK.Utilities.RedirProcess|7-exited: code 0, finished in 63 ms
2016-04-27 11:30:45.6786|INFO|Nvidia.PentaK.Utilities.RedirProcess|8-launch: D:\NVPACK1R4\android-sdk-windows\tools\android.bat "list targets" [D:\NVPACK1R4\android-sdk-windows\tools]
2016-04-27 11:30:46.1187|INFO|Nvidia.PentaK.Utilities.RedirProcess|8-stdout:
ERROR: SWT folder 'lib\x86_64' does not exist.
Please set ANDROID_SWT to point to the folder containing swt.jar for your platform.

2016-04-27 11:30:46.1187|INFO|Nvidia.PentaK.Utilities.RedirProcess|8-stderr:
Picked up _JAVA_OPTIONS: -Xmx512M

2016-04-27 11:30:46.1187|INFO|Nvidia.PentaK.Utilities.RedirProcess|8-exited: code 0, finished in 436 ms

Solved. I had to tick Eclipse and ADT in the Codeworks Component Manager. Guess Eclipse is not required, but ADT. But ADT get’s only included automatically if you include Eclipse. Maybe you should change that behaviour and include ADT always, even if Eclipse is not included?