Unable to create NvStreamMux ,pgie, nvvidconv, nvosd

Description

nvbuf_utils: Could not get EGL display connection
Unable to create NvStreamMux
Unable to create pgie
Unable to create nvvidconv
Unable to create nvosd
Creating EGLSink

Playing file /home/nvidia/juzheng/video/sample_0.mp4
Traceback (most recent call last):
File “deepstream_test_1.py”, line 266, in
sys.exit(main(sys.argv))
File “deepstream_test_1.py”, line 199, in main
streammux.set_property(‘width’, 1920)
AttributeError: ‘NoneType’ object has no attribute ‘set_property’

I cannot execute any demo with deepstream_python_apps.
The plug-in is in /usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream.

Environment

TensorRT Version: 7.13
GPU Type: agx
Nvidia Driver Version:
CUDA Version: 10.2
CUDNN Version: 8.0
Operating System + Version: ubuntu18.04
Python Version (if applicable): 3.6
deepstream (if applicable): 5.1
PyTorch Version (if applicable):
Baremetal or Container (if container which image + tag):

Hi @549981178,

This doesn’t look like Tensorrt issue. Please post your query in realted forum.

Thank you.

Hi,
Have you followed deepstream_python_apps/HOWTO.md at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub
to setup the environments?

Yes.
I found that the plugins are all in the blacklist.

1 Like

Please remove the cache rm ~/.cache/gstreamer-1.0/registry* and then run gst-inspect-1.0 and look for warnings/criticals from the plugin that was blacklisted.
and try again.