Unable to find shaders on local PC

First time user, using 3.0.0.13027 RC1, on my local laptop (Windows 7 x64, VS2010) debugging a x86 program.

No matter what I do, it always can’t find the shader files, even though it ran fine without Nsight. I thought it was the Nsight user properties window, but it’s still the same. In fact, as long as the path is relative, it won’t be able to load it and will always fail. Any ideas why?

edit: same for all files, not just shaders.

The Visual Studio debugger and Nsight debugger have a property to set the Current Working Directory. If this is left blank the Visual Studio C++ Debugger will use the project directory. The Nsight debugger has a separate property that I believe will use the vcxproj setting if it exists; otherwise, it will set it to the executable directory. I recommend explicitly setting the value to see if it resolves your problem:

  1. Open Solution Explorer
  2. Right click on the Startup Project and execute Nsight User Properties
  3. In the NVIDIA Nsight User Settings dialog select Launch
  4. In the Launch Options section set Working directory to the directory that you want to use as the current working directory.

Hi, thank you for the tip, that worked great!

However now that I can access it, there is no way for me to do debugging (stepping through) of the GLSL shader code nor see pixel history. If you can point in me the right direction, that would be great!

Hi, thank you for the tip, that worked great!

However now that I can access it, there is no way for me to do debugging (stepping through) of the GLSL shader code nor see pixel history. If you can point in me the right direction, that would be great!

Is this a GL 3.3 or GL 4.2 application?