Unable to find Titan Xp driver/ CUDA for Tensorflow 1.14

I have been running this system for a while.
Recently I upgraded tensorflow to 1.14 and Python 3.7x

OS is Linux Mint Sylvia 18.3 forked from Ubuntu 16.04.6 LTS (Xenial Xerus)

I have this Nvidia driver:

NVIDIA-SMI 384.130 Driver Version: 384.130

I got this error when I ran Tensorflow on Titan XP:

tensorflow.python.framework.errors_impl.InternalError: cudaGetDevice() failed.
Status: CUDA driver version is insufficient for CUDA runtime version

Here is my display hardware:

$ sudo lshw -class display
[sudo] password for ml:
*-display
description: VGA compatible controller
product: GP102 [TITAN Xp]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:21:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:122 memory:ec000000-ecffffff memory:d0000000-dfffffff memory:e0000000-e1ffffff ioport:7000(size=128) memory:ed000000-ed07ffff
*-display
description: VGA compatible controller
product: ASPEED Graphics Family
vendor: ASPEED Technology, Inc.
physical id: 0
bus info: pci@0000:42:00.0
version: 41
width: 32 bits
clock: 33MHz
capabilities: pm msi vga_controller cap_list
configuration: driver=ast latency=0
resources: irq:71 memory:ca000000-cbffffff memory:cc000000-cc01ffff ioport:b000(size=128)

============================
At https://www.nvidia.com/Download/index.aspx,
I tried downloading a new driver and there is no driver for Titan Xp.
See below.
Strange, I did install Titan Xp driver a about a 1-1/2 years or so ago…

[I am going to try and upload the png screenshot]

When “Download Type” was reset to “Studio Driver (SD)”, I got this search result response:

No certified downloads were found for this configuration. To include beta downloads in your search, click here

Questions:
Where can I get a new driver for Titan Xp for the newer TensorLow 1.14?
If I do get one, how do I install it over existing driver (NVIDIA Driver Version: 384.130 )?
I will also include a bug report here.
Thanks.

nvidia-bug-report.log.gz (85 KB)

choose game ready driver instead

how to install will depend on how you installed 384.130

Otherwise you can remove 384.130 and install a new driver.

Removal instructions are in the linux install guide for CUDA.

It has been a long time, I think I followed nvidia’s instruction on installing the driver.
Like I said above, I could not find the Titan Xp driver here:

https://www.nvidia.com/Download/index.aspx

when I specify TITAN Xp and Ubtuntu 16.04.
So how do I go about getting a new driver?

Addendum:
I looked here:
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#removing-cuda-tk-and-driver

  1. Removing CUDA Toolkit and Driver

choose linux 64-bit instead of ubuntu