Unable to Flash Custom Carrier Board - "Parsing Board Information Failed"

Hello everyone,

We are facing an issue while trying to flash our custom carrier board. The process fails with the error “parsing board information failed.” Here are the details of our setup:

  • Jetson Module: Jetson Orin NX 16GB
  • Host PC OS: Ubuntu 20.04
  • Tegra Version: Tried both 35.3 and 36.3

We have modified the EEPROM changes and have also tried using the stock kernel, but we are still unable to flash the board.
here is the screeshot of EEPROM changes

Could this issue be related to the hardware? If so, what might be the potential hardware issues and how can we resolve them?

Has anyone encountered a similar issue or have any insights on how to resolve this error?

here is the log for your reference.
flash_log_c2.txt (10.8 KB)

Thank you in advance for your help!

Hi,

Please at least tell me what files did you modify.
Your screenshots did not even show the file name…

Also, dump the log:

hello @DaveYYY

I have tried to capture logs from the serial port while flashing, but I did not receive any serial logs. However, when I flashed that SOM module and SSD and used them in this board, serial logs were printed. Here are those serial logs
bootlogs_custom.txt (22.9 KB)

the scrrenshot of eeprom changes

file = Linux_for_tegra/bootloader/generic/BCT/tegra234-mb2-bct-misc-p3767-0000.dts

You should delete the whole BSP and try again.

Modifying only this file is not enough because a copy of this file is generated under Linux_for_tegra/bootloader/, and this copy is the one that flashing tools use.