Unable to flash Jeston Xavier NX

Hi, I’m trying to install the libraries through the SDK Manager software on a Jetson Xavier NX.
I was able to start the process, connecting the Jetson to the host.
The process reaches about 35% and then I get this error.



I’ve checked and I have enough space on the device.
I’ve checked that both manually or automatically the device would correctly go in force-recovery state.
The device also has a 128GB nvme storage, that I’ve tried to flash to too but the process still isn’t working.
I haven’t been able to find a solution at this, I’m not an expert Linux user, so any help would be welcome.

Thanks

Is the host PC a native Ubuntu 18.04? If it is a VM or container, then I’d expect similar issues. If the host PC is a native Ubuntu 18.04, then something else is going on, e.g., try to unplug and replug the USB cable when this occurs, or if using a HUB, go directly to the PC instead of via the HUB.

Hi, thank you for the answer.
My PC has both Win10 and Ubuntu 18.04 in dual boot.
I’m not using a HUB, but I’m using a small adapter from USB-A to USB-C to connect the other end of the micro-USB cable to my host PC.
Do you think that could be the issue?

Have you tried to manually use flash.sh?

Is your board able to boot into ubuntu ? If so, could you run command “sudo reboot forced-recovery” and it shall put the board into recovery mode.

Hi, the only thing different that I’ve done is using an older PC that has a USB-A port so I could remove the USB-C adapter, and now the installation has worked. The problem is that during the flashing part when the Jetson reboots after the creation of the user, I get errors in the boot prompt and the system is stuck with:
[ OK ] Started Update UTMP about System Runlevel Changes.
[ OK ] Started User Manager for UID 1000.
I’m looking for solutions online but I can’t find any that works for me.
Do you have an idea what it might be?
The SDK Manager installation from the host didn’t show any error and completed successfully.
It’s a pretty fresh Jetson, because I just started using it, so I don’t think I’ve modified any important file before flashing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.