Unable to flash NVMe M.2 SSD

I am unable to successfully flash my SSD. Here are the commands I tried and the outputs of those commands. What is strange is that the QSPI flash is getting flashed just fine, but not the SSD. So, after attempting the flashing, the Jetson boots the kernel and gets to the Nvidia splash screen but then it halts.

Any ideas? I have tried multiple different SSDs.

custom_flash.sh:
UDISKS2_ACTIVE=$(sudo systemctl is-active udisks2.service)

trap cleanup 1 2 3 6

L4T_DIRECTORY="R32.6.1/Linux_for_Tegra"

cleanup()
{
  if [[ ${UDISKS2_ACTIVE} == 'active' ]] ; then
    echo "enabling usb mass storage devices"
    sudo systemctl start udisks2.service
  fi
  exit
}

function flash_jetson
{
  cd $L4T_DIRECTORY
  echo "disabling usb mass storage devices"
  sudo systemctl stop udisks2.service
  read -p "Press enter to generate internal image..."
  sudo ./tools/kernel_flash/l4t_initrd_flash.sh --no-flash jetson-agx-xavier-devkit internal
  read -p "Press enter to generate external encrypted image..."
  sudo ROOTFS_ENC=1 ./tools/kernel_flash/l4t_initrd_flash.sh --no-flash \
            --external-device nvme0n1p1 \
            -S 8GiB -c ./tools/kernel_flash/flash_l4t_nvme_rootfs_enc.xml \
            --external-only --append jetson-agx-xavier-devkit external
  read -p "Press enter to flash both images..."
  sudo ./tools/kernel_flash/l4t_initrd_flash.sh --flash-only

  cleanup
}

flash_jetson

Output of results exceeds the character limit for a post so I have to upload attachments:
custom_flash_output.txt (251.4 KB)
console_boot_attempt.txt (34.7 KB)

Please follow the guide and check the readme file.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E0SK0HA

According to the log, it seems the sd card is not detected.

if your nx sd does not have sd card you can use
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --no-flash jetson-xavier-nx-devkit-qspi internal

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.