Unable to Flash Orin (CRC8 error, calculated !=stored)

Hi, I am trying to reflash a Jetson Orin Dev kit, but it fails.

The error I get is:

edit: sorry, should have included more details.

  • Host PC is a desktop running Ubuntu 20.04
  • The owner of the orin tried to upgrade his l4t version from 34.1 to 35.3.
  • the orin was running ubuntu 20.04, I believe Jetson 5.0.1

SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_AGX_Orin_modules_2023-08-24_09-52-43.zip (217.1 KB)

Hi,

did you made any modification to the EEPROM on the module?
Looks like the checksum bit is incorrect.

If you can still get in to the Ubuntu system, please run the command to correct it:

sudo i2cset -y -f 0 0x50 0xff 0x9d

1 Like

@DaveYYY
I don’t know the exact details of what he did to the device.
The device turns on and is detected by sdkmanager, but there’s no video output.

Can’t seem to access it with minicom either. lsusb does not show it when it’s on (but does when its in recovery).

edit: Got it to contact minicom with a micro-usb cable.

got into minicom, ran the command and its at least attempting to flash now (instead of an instant fail warning).

will update after it (hopefully) completes.

update:

It succesfully flashed. Plugged it into a monitor, had the wall of text pop out but then it was stuck with a black screen.

Tried restarting but now its just straight to a black screen.

Any serial console log to provide?
Is it a DevKit or a custom carrier board?

It is a Jetson Orin DevKit

Managed to get it to work. I re-flashed it and set the setup at runtime instead of pre-config.

Seemed to have fixed the issue.

Thanks for the solution.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.