Unable to flash with Jetpack SDK Manager

Hi, I have put my Xavier dev kit into recovery mode. Doing lsusb does show that it is being detected:
Bus 001 Device 006: ID 0955:7019 NVidia Corp.

However, the jetpack SDK manager keeps failing to detect the device while attempting to flash the OS. Below is a snippet from the terminal:

  • 22:18:02 INFO : Flash Jetson AGX Xavier : exec_command: sudo ./flash.sh jetson-xavier mmcblk0p1
  • 22:18:02 INFO : Flash Jetson AGX Xavier : ###############################################################################
  • 22:18:02 INFO : Flash Jetson AGX Xavier : # L4T BSP Information:
  • 22:18:02 INFO : Flash Jetson AGX Xavier : # R32 , REVISION: 3.1
  • 22:18:02 INFO : Flash Jetson AGX Xavier : ###############################################################################
  • 22:18:05 INFO : Flash Jetson AGX Xavier : Error: probing the target board failed.
  • 22:18:05 INFO : Flash Jetson AGX Xavier : Make sure the target board is connected through
  • 22:18:05 INFO : Flash Jetson AGX Xavier : USB port and is in recovery mode.
  • 22:18:05 INFO : Flash Jetson AGX Xavier : exit status 1

Anyone has an idea of whats wrong?

A Jetson tends to disconnect and reconnect on USB over and over during a flash. If you are using a VM, then the VM usually fails to reacquire USB at reconnect. Are you using a VM?

No I am not using a VM. I switched to another computer and it worked. Seems like some weird issue (among a hell lot of other weird issues) with Dell XPS15 9570. Thanks anyway!

There have been some Intel NUCs and older laptops where USB gave similar issues. This does not occur much, but is also not entirely “rare”. If things work from another computer, then you’ve found one of those odd laptops.

for people having the same problem, just do:

sudo apt remove tlp

reboot and it should work

Reference: TX2...probing the target board failed(ok) - #2 by linuxdev