Unable to get Xorg running with NVIDIA proprietary driver on SuperMicro box with GRID K1s and Fedora

I can’t get the proprietary NVIDIA driver to run on our SYS-1017GR-TF SuperMicro box with two K1 GRID cards. So far I’ve tried Fedora 20, Xorg server 1.14.4, and proprietary drivers 337.25, 340.17, 331.79, and 304.121 along with one and two GRID K1 cards installed.

The strange thing in all this is that Xorg claims no devices are found

Xorg -logverbose 6

cat /var/log/Xorg.0.log


[ 1086.926] (II) LoadModule: “glx”
[ 1086.926] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 1086.944] (II) Module glx: vendor=“NVIDIA Corporation”
[ 1086.944] compiled for 4.0.2, module version = 1.0.0
[ 1086.944] Module class: X.Org Server Extension
[ 1086.944] (II) NVIDIA GLX Module 337.25 Tue May 27 12:21:38 PDT 2014
[ 1086.944] Loading extension GLX
[ 1086.945] (II) LoadModule: “nvidia”
[ 1086.945] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 1086.945] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 1086.945] compiled for 4.0.2, module version = 1.0.0
[ 1086.945] Module class: X.Org Video Driver
[ 1086.945] (II) NVIDIA dlloader X Driver 337.25 Tue May 27 12:01:55 PDT 2014
[ 1086.945] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 1086.945] (II) NVIDIA X compatibility module for ABI 14.0 built from xorg-server-1.13.99.901
[ 1086.945] (II) X log verbosity: 6
[ 1086.945] (–) using VT number 2

[ 1086.978] (EE) No devices detected.
[ 1086.978] (EE)
Fatal server error:
[ 1086.978] (EE) no screens found(EE)
[ 1086.979] (EE)
Please consult the Fedora Project support
at http://wiki.x.org
for help.
[ 1086.979] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 1086.979] (EE)

but nvidia-smi has no such problems

nvidia-smi -L

GPU 0: GRID K1 (UUID: GPU-1806102a-04c1-a756-66ec-c52ddcabefa3)
GPU 1: GRID K1 (UUID: GPU-ebf18115-0b1f-5346-14e0-d8429affdf16)
GPU 2: GRID K1 (UUID: GPU-9688b845-2f60-f86d-7c6f-a4c9d76dc737)
GPU 3: GRID K1 (UUID: GPU-a456a7a0-d673-3d52-ff37-7587ae50a1cb)

I installed the drivers by downloading the “NVIDIA-Linux-x86-64-.run” directly from the nvidia site and running it. The Xorg.conf file is the one generated by “nvidia-xconfig” (I’ve also tried one that just had a “Device” section for the nvidia driver with and without the “AllowEmptyInitialConfiguration” and “UseDisplayDevice” “none” options but to no avail).

I’m posting the nvidia-bug-report.log.gz file as instructed in the “if you have a problem, PLEASE read this first post” on our website. Any help anyone can give me would be greatly appreciated.

http://www.sharcnet.ca/~tyson/nvidia-bug-report.log.gz

Thanks! -Tyson
nvidia-bug-report.log.gz (531 KB)

The primary VGA device in that system is a Matrox “MGA G200eW WPCM450”. Does X work if you specify the BusID of the GPU you want to use?

Thanks for the suggestion. I’ll give this a try and get back to you.

(it might be a few days as it is down for service due to some new POST issues)

Got it POSTing again with a manual CMOS reset.

Pleased to report that adding the BusIDs results in Xorg working as expected.

Thank you very much for the assistance!

Cheers! -Tyson

Do you have any documentation on how to do this? I think this might be my issue.

Thanks