Unable to install CUDA 5.0 in gtx 850m


I’m trying to install CUDA on my laptop’s GeForce GTX 850m(installed driver: 398.36) and can’t manage to do it.

I’m new to this and it can be very simple. I’m getting the error while running the nbody_vs2010.sln

“C:\ProgramData\NVIDIA Corporation\CUDA Samples\v5.0\5_Simulations\nbody\nbody_vs2010.vcxproj : error : Unable to read the project file “nbody_vs2010.vcxproj”.
C:\ProgramData\NVIDIA Corporation\CUDA Samples\v5.0\5_Simulations\nbody\nbody_vs2010.vcxproj(234,5): The imported project “C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\v110\BuildCustomizations\CUDA 5.0.targets” was not found. Confirm that the path in the declaration is correct, and that the file exists on disk.”

A few things to be noted:
I’m using VS2012, because VS2010 says the files were made in a more recent version.
I’m getting the .targets error but I was getting the .props until I found it hanging somewhere in my pc and copied.
I tried reinstalling CUDA and all kinds of Visual Studio over and over again to no luck.

The purpose of the installation is for Electrical Engineering real time simulations, so I need a nice computer power and I want to test GPU.

I’m running Windows 10-64bits even if the software compatibility is for Win 8 tops. I can’t afford to downgrade.
My processor, if its necessary, is a i7-4810MQ.

I don’t think you’ll be able to read a vs2010 project or solution file into vs2012. I’m not sure why you would want to install such an old CUDA version (5.0).

Well, the compatibility table says 5.0 is the one I should use… Or did I read it wrong and its 5.0 or newer?
I’ll give it a try.

You read it wrong. The “compatibility table” is actual a table of CUDA compute capability. That is not the same as compatibility with a particular CUDA version.

CUDA 9.x supports GPUs of compute capability 3.0 and higher.

I manage to install but I was sick. I’ll give a try today and see if the matter is solved.

This also means I can try using VS2017. I’ll test that too.