unable to install cuda in ubuntu 16.04 in any way

I had a previous installation of CUDA in ubuntu 16.04 ,i tried unisnstalling and installin again beacause the example deviceQuery did not work properly.

on trying .run install iget
EGL_VENDOR string “NVIDIA”, expected “DUMMY VENDOR”-> An incomplete installation of libglvnd was found

on trying .deb network install i get
Executing: /tmp/tmp.rVoIBqLHVH/gpg.1.sh --fetch-keys
https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/7fa2af80.pub
gpgkeys: protocol https' not supported gpg: no handler for keyserver scheme https’
gpg: WARNING: unable to fetch URI https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/7fa2af80.pub: keyserver error

strangely nvcc -V works

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2015 NVIDIA Corporation
Built on Tue_Aug_11_14:27:32_CDT_2015
Cuda compilation tools, release 7.5, V7.5.17

Hi there,

I’m receiveing exactly the same issue… any progress?
Thanks

Hi there,

I’m receiveing exactly the same issue… any progress?
Thanks

I am facing the same problem. looking forward to someone solving this!

Hi Guys…

I recently uninstalled and reinstalled my cuda drivers many many times traying to get the new GPU drivers work with cuda and never get this errors you are talking about.
Try to purge the files from your system and install from local repository , download everything again maybe something is corrupted.

I believe you already know and did this but check this steps,
everytime I get some error I repeat this:

  • remove the cuda
  • purge it
  • remove the cuda repository folders at /vars
  • remove the .list files for “cuda” in /etc/apt/sources.list.d
  • restart the machine
  • download the deb for local repository
  • register the keys again
  • install the repository
  • install the cuda and drivers

So, I tried re-installing ubuntu and tried multiple times. Still have the same issue.

Hi…

Very strange indeed, I have many machines here and if it was a ubuntu problem I would had the same problem.
Reinstalling ubuntu following the correct steps also would had solved.
But since something unexplicable is going on let me post my setup pipeline. If you can try reproduce it there.

[UPDATED: accidentally I have posted in bad order the first time, now it’s ok]
[UPDATED: cuda-9.1]

  1. Install ubuntu 16.04.3 LTS
  2. Download cuda local repository for Ubuntu 16.04 (1.2Gb)
    wget https://developer.nvidia.com/compute/cuda/9.1/Prod/local_installers/cuda-repo-ubuntu1604-9-1-local_9.1.85-1_amd64
    
  3. Install the repository locally
    sudo dpkg -i cuda-repo-ubuntu1604-9-1-local_9.1.85-1_amd64.deb
    
  4. Register Nvidia Key
    sudo apt-key add /var/cuda-repo-9-1-local/7fa2af80.pub
    
  5. Update and install cuda and nvidia-drivers
    sudo apt-get update && sudo apt-get install -y cuda
    
  6. change the path
    export PATH=/usr/local/cuda-9.1/bin${PATH:+:${PATH}}
    export LD_LIBRARY_PATH=/usr/local/cuda-9.1/lib64 ${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
    
  7. To verify if the video card is correctly installed execute
    nvidia-smi
    

ATTENTION: cuda 9.1 installs the most recent nvidia-387.xx driver!!!

Let me know if still not works.
Regards

hi guys,

i have much quretions to intalled CUDA,can you tell me to intall some ways or doctments,ok? thank you very much .

Sorry but I don’t understand your question.

Anyway, above has step by step how to install Cuda from a local repository.

Any solution to this issue?

Installation guide.
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

Differing from cuda 8-0/9-2/10-1, it seems that cuda-repo-ubuntu1404-7-5-local_7.5-18_amd64.deb contains no 7fa2af80.pub, but a file named GPGKEY, which indicates the GnuPG v2.0.9 KEY was used.

I always use the network deb instead of the local deb. Never have a problem