Unable to install CUDA supported Pytorch in JN

Using ‘NVidia jetpack 4.5.1-b17’ and ‘nvidia-l4t-core 32.5.1-20210219084526’ of ‘architecture arm64’ and ‘Python V-3.6.9’
Wants to install ‘Pytorch- CUDA supported’ library without updating Jetpack or l4t version.
Already installed ‘CUDA V-10.2’, ‘Pytorch V-2.1.0’ and ‘Pytorchvision V-0.16.0’ but Pytorch is not CUDA supported.

How can I install CUDA supported Pytorch without changing/updating Jetpack or l4t version.?

Hi, @hareshp

This is forum for cuda-gdb tool. I’m sorry I am not familiar with jetpack/l4t installation. It seems you post a same question before and have been moved to jetpack https://forums.developer.nvidia.com/t/unable-to-install-cuda-supported-pytorch-in-jn/276843

Hi, @veraj
Thank you for the response, the moved question page is not accessible to me,
It is showing ‘Page Not Found - Sorry, this page may have moved, doesn’t exist or is private’.

Can you help me out here, by checking if page is private/public.

Sorry for the trouble caused. That forum seems private.

What about Frameworks - NVIDIA Developer Forums, do you think this forum is more suitable for your questions ?

  1. Can you make it public.?
  2. Thank you for sharing, I will look into this.

I moved your original topic, see Unable to install CUDA supported Pytorch in JN.

Hope you can get good support there. Thanks !

Thank you @veraj,
can you please concern any person who is familiar with Jetpack and pytorch installation.?

Hi, @hareshp

I asked internally. Pytorch is supported since JP5.0. See Index of /compute/redist/jp, you can see there is Pytorch since v50.

If you want to install Pytorch separately, you can follow instructions in Installing PyTorch for Jetson Platform - NVIDIA Docs.
But we are not sure if it can work. You can have a try.

Regarding cuda installation, you can get package from here and have a try https://developer.nvidia.com/cuda-12-2-0-download-archive?target_os=Linux&target_arch=aarch64-jetson&Compilation=Native&Distribution=Ubuntu&target_version=20.04&target_type=deb_network

@veraj,
I have already installed CUDA 10.2, thank you for the reference.
Also, I am using Jetson Tegra 210, and Jetpack 5.0 is not supported for t210, latest one is 4.6

Do you have any idea of Pytorch (CUDA supported) availability for Jetson Nano (tegra 210)…?

Sorry. I don’t know about this. I am afraid there is no support. Please check in Jetson Nano forum.

Ohk, @veraj.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.