Unable to install drivers on kde neon 18.04 kernel 4.15


Setting my kde neon on a dell precision m3800 wit quadro k1100m

For the past few days i can’t manage to get nvidia drivers to get working, so far my diagnosis is that nvidia-drm cannot be installed.

So far i tried installing all of the latest drivers including: 384 390 396 410
this was fone by first purging the old drivers

Tried installing cuda 10.0 following the instructions

Tried installing 410/396 drivers following with 10/9.2 cuda-toolkit

Tried installing with xorg stoped

tried dissabling noveau opensoure drivers

still no luck, am i missing something?

How did you install the driver/cuda?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

Cuda was installed by installing dbkg -i file and then running usual apt-get install

I tried installing drivers by

1.sudo apt-get install nvidia-driver-XXX


3.sudo ubuntu-drivers autoinstall

4.By turning off the xorg and then installing with all the methods.

Since it’s an Optimus notebook, don’t use the .run installer.

  • purge anything nvidia/cuda you installed, especially the .run installer using the --uninstall option
  • uninstall bumblebee
  • use the ubuntu graphics ppa to install the latest driver, check that nvidia-prime is installed.
  • use ‘sudo prime-select nvidia’ to switch to nvidia profile
    if everything works, you can install cuda:
  • download/follow the instructions to add the .deb to your system
  • don’t install cuda
  • instead, use ‘sudo apt install cuda-toolkit-10-0’ to just install the toolkit.

The log i provided is done after these steps, no bueno, i always purge nvidia/cuda before each try.

No bumblebee on the system.

sudo prime-select nvidia

lspci -k | grep -A 2 -E "(VGA|3D)"


00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: Dell 4th Gen Core Processor Integrated Graphics Controller
        Kernel driver in use: i915
02:00.0 3D controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)
        Subsystem: Dell GK107GLM [Quadro K1100M]
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
sudo prime-select nvidia
Info: the nvidia profile is already set

Please check if the file
exists and delete it.
Furthermore, either your dvd drive is broken or has a bad cd/dvd inserted so that the log is flooded with read errors from that. Please remove it and create a new nvidia-bug-report.log

It works after deleting

You are my hero, can you explain wtf was that all about? How that blacklist got there?

And the errors are from external hdd, don’t worry about it, it’s a workhorse.

It’s an Ubuntu bug that has been introduced with the latest nvidia-prime package update. It creates that file and then forgets about it.