Unable to install or uninstall Nsight Tegra, Visual Studio Edition

I installed CodeWorks for Android 1R7 and found that nothing was installed on the Visual Studio 2017.
Now, if I try to uninstall or reinstall, the CodeWorks installer fails with :

Uninstalling Nsight Tegra, Visual Studio Edition 3.5. failed.

Return Code: 2
panic: runtime error: index out of range

Now I can’t program android neither on 2017 nor reinstall 1R5 for 2015

Hi diego.martinez and sorry for the late reply.
What is the full version of Visual Studio 2017 (including the updates) installed on the PC?
Can you please try installing Nsight Tegra Visual Studio Edition 3.5 manually, by downloading the standalone installer from https://developer.nvidia.com/nvidia-nsight-tegra or locating the MSI in the CodeWorks cache directory.

I am experiencing the same issue.
My old PC finally gave up and I setup a complete fresh Intel System yesterday.

  • installed Windows 10 (latest version, all updates)
  • installed Visual Studio Community 2017 (with all updates)
  • installed CodeWorks

Visual Studio does not show any signs of Nsight Tegra integration.
I de-installed and installed it again multiple times using the MSI in the cache directory.
Also tried on a administrator account.

It simply does not seem to integrate itself.

Please advise.

Hi!
Please, open the directory c:\Program Files (x86)\NVIDIA Corporation\Nsight Tegra 3.x there X stands for 5 or 6, dependending on the Nsight Tegra VSE version.
There’s a bunch of .log files in the directory, please archive them and attach to this thread.
IF the Nsight Tegra VSI MSI is installed (check that in Add/Remove programs) the VSIX package file is present in the aforementioned product installation directory.
Double click on VSIX to run VSIX installer (note that it’s a different program from VS installer) that will integrate the package into Visual Studio.
It’s likely that your shiny new VS '17 installation lacks a component required by NT VSE VSIX package.
Please attach the screenshot of VSIX installer window to confirm this idea.

Thank you for the fast and helpful response!
You were right, everything was as you expected.

I run the VSIX, it did some things, and afterwards everything worked!
I am really glad this turned out like this.

I can’t seem to find an attach option here.
If you message me privately I can email you the zip file. It might also contain some data which I do not want to be visible by everyone else here.

Thank you!

[quote=“diego.martinez, post:1, topic:67124”]
Now, if I try to uninstall or reinstall, the CodeWorks installer fails with :
[/quote]>snaptube word to pdf vidmate

Now, if I try to uninstall or reinstall, the CodeWorks installer fails with :