Unable to install RAPIDS cuML on Jetson Orin NX with Python 3.9

I can’t install RAPIDS (cuML and related libraries) using pip following Installation Guide - RAPIDS Docs.
I have tried all recent RAPIDS version from 23.04 to 23.10 and all produce the same error.

The error is:

My sys info is:
Ubuntu 20.04.2
JetPack 5.1.1
Python 3.8 and 3.9 both exist (Since Ubuntu builds on Python 3.8, I didn’t uninstall 3.8 but point default/sys Python version to 3.9 to satisfy RAPIDS prerequisites)
CUDA 11.4.315

Much appreciated if someone can give a help.


Please check the below topic for info:


Thanks for the reply. However, the post has been outdated since RAPIDS have had a major release (2023.7) to support jetson now. Is there any other possible solution?

@yuxin.xuan RAPIDS isn’t officially supported on Jetson and can be tricky to build. I have some container images built for cuDF and cuML at GitHub - dusty-nv/jetson-containers: Machine Learning Containers for NVIDIA Jetson and JetPack-L4T , but they are using some older versions that work on JetPack 5. I should be able to update them to newer versions when JetPack 6 comes out.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.