Unable to install Steam on Jetson Nano

Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386
[sudo] password for jim:

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgl1-mesa-dri:i386
E: Unable to locate package libgl1-mesa-glx:i386
E: Unable to locate package libc6:i386
Press return to continue:

i386 means this package was built for x86 and not ARM. The package maintainer would need to provide version made for ARM aarch64, or the source code so you could compile it yourself.

so is there any way of getting this to install then?

There appears to be two packages related to steam in Ubuntu 18.04’s aarch64 repository: steam-devices and steam-installer. I don’t know if those are what you are looking for, but you could try installing them with apt.

EDIT: steam-devices installed fine for me on Nano, but steam-installer wouldn’t install because it depends on steam package, which isn’t available from Ubuntu. So it appears that Valve would need to provide this package for ARM Linux aarch64 architecture.

Hi,

thank you for your help,yes i tried the same and got same result. worth a try.

Kind Regards.