Unable to load 470 nvidia rtx 3080 driver, despite it being installed on (focal uses Intel Mesa)

nvidia-settings

ERROR: NVIDIA driver is not loaded

I know this is a problem that plenty of people have encountered before, but none of the solutions seem to do it for me. I had it working before, but after I was trying to solve another issue, I purged the driver and now I can’t seem to get it back.

dkms status shows it being installed (used the one found @Software&updates), secure boot is disabled, Nouveau is blacklisted

nvidia log file:

data (1.8 MB)

The driver seems to be blacklisted, please

  • run
sudo prime-select nvidia
  • run
grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

blacklist nvidia

and remove it,
then run

sudo update-initramfs -u

and reboot.

I found a blacklist-framebuffer.conf, that had blacklist nvidiafb. Deleting that file, updating initramfs and rebooting did not help.

nvidia-bug-report.log (1.8 MB)

Please recreate that file, nvidiafb needs to be blacklisted.
Seems the installed module is broken then, please run
sudo dkms remove nvidia/470.86 --all
sudo dkms install nvidia/470.86
afterwards, check if it properly loads
sudo modprobe nvidia

sudo modprobe nvidia returned:
modprobe: ERROR: could not insert ‘nvidia’: Exec format error

nvidia-bug-report.log (1.8 MB)

Did you remove and re-install the module using dkms?

Yes, rebooted afterwards

Please post the output of
cc -v

Using built-in specs.
COLLECT_GCC=cc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 9.3.0-17ubuntu1~20.04’ --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)

cc.txt (1.3 KB)

Something is broken in your build chain so no working modules can be compiled. Please uninstall the kernel headers and reinstall them.

1 Like

I ran sudo apt install --reinstall linux-headers-generic
cc.txt (1.3 KB)
Same output

Did you remove/install the module using dkms afterwards? this has to be done most times after a change.

Thank you so much, that fixed it!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.