Unable to load driver module nvidia.ko when installing on Linux Centos 6.3

I have a 64 bit machine with a fresh install of Centos 6.3, and I am unable to install the NVIDIA drivers. I have tried both NVIDIA-Linux-x86_64-304.64 and NVIDIA-Linux-x86_64-310.32.

I boot the system into init 3 to avoid any problems starting the Xserver.

The nouveau driver is blacklisted, and when I run lspci it does not appear to have a kernel driver actually in use for the nvidia card (no line saying kernel driver in use appears anyway).

The specific kernel version in use (/proc/version) is:

Linux version 2.6.32-279.el6.x86_64 (mockbuild@c6b9.bsys.dev.centos.org) (gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC) ) #1 SMP Fri Jun 22 12:19:21 UTC 2012

I installed the source files using the kernel-devel package, then I use the kernel-source-path and kernel-include path to specify the location of these source files at /usr/src/kernels/2.6.32-279.19.1.el6.x86_64/ and /usr/src/kernels/2.6.32-279.19.1.el6.x86_64/include respectively.

The nvidia driver appears to build properly, but it gives me an error at the end saying it was unable to load the driver nvidia.ko, and gives the common problems as being the kernel source & include mismatches, or that another driver is present. As far as I can tell, there is no other driver in use, and X Windows is not running.

I disabled SELinux as well.

I get the following at the end of the nvidia_installer.log file:

ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present
hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_
pos_adj.
fuse init (API version 7.13)
mtrr: no MTRR for d5000000,e00000 found
nvidia: module license ‘NVIDIA’ taints kernel.
Disabling lock debugging due to kernel taint
nvidia: Unknown symbol kmem_cache_alloc_trace
mtrr: no MTRR for d5000000,e00000 found
nvidia: Unknown symbol kmem_cache_alloc_trace
nvidia: Unknown symbol kmem_cache_alloc_trace
nvidia: Unknown symbol kmem_cache_alloc_trace
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.
log’ for details. You may find suggestions on fixing installation problems in t
he README available on the Linux driver download page at www.nvidia.com.
dan@localhost:~/Desktop$

My guess is that the real issue is the kmem_cache_alloc_trace symbol. Anyone have any ideas?

Looks like I was able to use ELRepos nvidia driver successfully. Still no idea why I couldn’t use nvidia’s script, but maybe it doesn’t matter. I’ll see if I still have trouble when I try to get the CUDA SDK installed.