Unable to load Nvidia drivers on POWER8 S822LC with Ubuntu 16.04.2 LTS

I have received a POWER8 S822LC server with two P100 GPU’s and no OS.
I loaded Ubuntu 16.04.2 LTS with no issues.
The kernel level is 4.8.0-36-generic (ppc64el)
I tried loading the nvidia driver 361.107 after installing gcc5 and the kernel header packages.
It gives the following error:
Building initial module for 4.8.0-36-generic
Error! Bad return status for module build on kernel: 4.8.0-36-generic (ppc64el)

the associated make.log shows the following:
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol ‘mmu_feature_keys’
scripts/Makefile.modpost:91: recipe for target ‘__modpost’ failed
make[2]: *** [__modpost] Error 1
Makefile:1494: recipe for target ‘modules’ failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-4.8.0-36-generic’
Makefile:81: recipe for target ‘modules’ failed
make: *** [modules] Error 2

running nvidia-smi gives the following error:
modprobe: ERROR: …/libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name=‘nvidia_361’
modprobe: ERROR: could not insert ‘nvidia_361’: Unknown symbol in module, or unknown parameter (see dmesg)
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried the later version of the nvidia driver 375.39 after cleaning up the earlier driver install. Still no joy. What gives?

Are the nvidia P100 drivers not compatible with Ubuntu 16.04.2 LTS and the associated kernel 4.8.0-36? If so, is Ubuntu 16.04.1 LTS compatible or should I revert back to 16.04 LTS?

Thanks and kind regards
Sarge Thomas

Alright, so I went back and reinstalled Ubuntu 16.04.
Followed that up with a CUDA8 install and this time, nvidia-smi shows the relevant GPU’s

Wed Mar 8 22:22:49 2017
| NVIDIA-SMI 361.107 Driver Version: 361.107 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Tesla P100-SXM2… Off | 0002:01:00.0 Off | 0 |
| N/A 28C P0 35W / 300W | 0MiB / 16280MiB | 0% Default |
| 1 Tesla P100-SXM2… Off | 0006:01:00.0 Off | 0 |
| N/A 27C P0 33W / 300W | 0MiB / 16280MiB | 0% Default |

Moral of the story: Nvidia drivers aren’t necessarily in sync with Ubuntu LTS updates.
Downside: I couldn’t find any logical nvidia document/webpage that shows the Ubuntu release/version support.

Anybody had a different experience in terms of documentation?

Thanks, Sarge Thomas