Unable to locate package linux-headers-4.9.253-tegra

Hi,
I have a Jetson Nano production module with a Auvidea JNX30 Carrier Board. I have set up the Jetson Nano with flash.sh script. Everything works fine until I want to install a driver for a 10Gbit/s network card. The following error occurred:

dpkg-query: no packages found matching linux-headers-4.9.253-tegra
Please install the necessary packages linux-headers-4.9.253-tegra.
Example: sudo apt-get install linux-headers-4.9.253-tegra.

Additionally it is still not possible to install the missing headers via apt because I got the following output:

E: Unable to locate package linux-headers-4.9.253-tegra
E: Couldn't find any package by glob 'linux-headers-4.9.253-tegra'
E: Couldn't find any package by regex 'linux-headers-4.9.253-tegra'

Furthermore, I found this guide Request: Install Linux Headers on Jetson Nano but the headers are still not found. Additionally I installed the generic version of the headers but also this did not brought the success.

Then I have searched for a repository with these headers and found the following:
Nvidia Repo

I added this repository to my /etc/apt/sources.list and installed the following package:

nvidia-l4t-kernel-headers_4.9.253-tegra-32.6.1-20210726122000_arm64.deb

Unfortunately, it still not works. But I noticed that the name of the package is slightly different.
Afterwards I installed the headers via the following link:
kernel_headers.tbz2
into my L4T before flashing nvidia jetson nano.
I also took a look into my L4T and noticed that the headers are already there:

rootfs/usr/src/linux-headers-4.9.253-tegra-ubuntu18.04_aarch64/kernel-4.9

What am I doing wrong because I still get the error that the headers are unable to locate? Am I using the wrong headers? Do I have to link the headers to a specific directory?

@hech10311 is this a PCIe extension card?

The overall process of enabling a device onto the BSP is first building the device driver as you build the kernel sources, making sure the driver is included in the build (makefiles and .config). Also the device-tree should be configure to enable and set up the device.

Hello mike_nv

Yes I am using a PCIe extension card. I have enabled the device tree and I will try to integrate the driver in the build.