Unable to login after flashing to DRIVE OS 5.2.6 on DRIVE AGX

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Hello Team,
We are unable to login to DRIVE AGX after upgrading from DRIVE SW 10.0 to DRIVE OS 5.2.6 using the default login nvidia\nvidia. Same login was provided during installation setup.
N.B. - Login fails when using ssh as well as minicom.
Please find the below attachment for installation logs from SDKmanager.
SDKM_logs_2021-10-24_00-16-55.zip (2.4 MB)

Hello Team,
Any update on this issue.

Hi, @ankitm4

Is it possible you had a typo in inputting the password? Have you tried to reflash it?

Hi @VickNV,
Yes, I have tried reflashing the hardware numerous times and also made sure that there is no typo. The same login credentials i.e. nvidia\nvidia works on DRIVE SW 10.0 (rev2). However once flashed to DRIVE OS 5.2.6, both the ssh and minicom based login attempts fail for the same.
I have also tried below combinations -

  • DRIVE SW 10.0 (rev2) → DRIVE OS 5.2.6
  • DRIVE SW 10.0 (rev2) → DRIVE OS 5.2.0
  • DRIVE SW 10.0 (rev2) → DRIVE OS 5.2.0 → DRIVE OS 5.2.6

In all the above listed cases, I was always able to login only for DRIVE SW 10.0 flash. Other versions kept failing for numerous login attempts.
Login with ubuntu\ubuntu credentials also fails.

My issue seem quite similar to below hyperlinks, however none seem to provide a fix for the same -
Not able to log in to DRIVE Xavier
AGX Pegasus how to change login password

Hi @VickNV ,
I was able to resolve this issue, however there seems to be an issue with the sdkmanager. During flash process it asks for the host admin password and then desired password for target i.e. nvidia\nvidia while the actual login password set on hardware post flash procedure is the original host admin password.
e.g. -
Generally -
hostPC: hostUser/hostPass
targetBoard: nvidia/nvidia
After flashing with DRIVE OS 5.2.6 (actual)-
hostPC: hostUser/hostPass
targetBoard: nvidia/hostPass

Glad to hear you figured out the problem. I haven’t encountered the issue though.

saw the same problem here, sdk manager assign host admin password to target

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

@ankitm4 / @hfkou
Is it possible you once accidentally input your admin password as the target password? Due to the issue discussed in the below topic, the wrong username/password was kept in /persistent storage, and then following reflashing with desire password didn’t work anymore.

Hi @VickNV,

Unfortunately I have also encountered this issue when flashing DriveOS 5.2.0 with SDK Manager
I am pretty sure, that I never gave my host password by accident as a target password.

Could it be a bug in newer SDK Manager versions?

Thank you!

Dear @krisztian.holman,
Does that mean if you reflash the target again with DRIVE OS 5.2.0, you still could not login with new credentials? Have you installed target with DRIVE OS 5.2.6 before? If so, could you check clearing the persistent storage as discussed in How to do factory reset for both Xavier modules on DRIVE AGX? Drive OS reinstall at least does not change the nvidia password

Dear @SivaRamaKrishnaNV ,

The target had DriveOS5.2.6 before, but it was flashed by another user, therefore the target should not know my credentials from previous flashing sessions. I had a few consecutive attempts with DriveOS 5.2.0, to make sure I did not make any typos.

With previous SDK Manager versions we did not experience this issue, that is why I assume it is related to the SDK Manager.

I could change the password on the target, but I do not think this explains, why the host user password is used in the first place.

Thank you!

Dear @SivaRamaKrishnaNV,

I have tried resetting the persistent storage: How to do factory reset for both Xavier modules on DRIVE AGX? Drive OS reinstall at least does not change the nvidia password

Although bootburn was successfully executed, I do not get the oem config screens and now the password is set once again to the host password.

When executing bootburn.sh it asks for the host password:

./tools/host/flashtools/bootburn/bootburn.sh -b e3550b03-t194a -B qspi
Execute Xavier Script
FlashCommandLineFromUser : -b e3550b03-t194a -B qspi 
Using Python scripts
Bootburn Starting with arguments ['./bootburn.py', '-b', 'e3550b03-t194a', '-B', 'qspi']
board is e3550b03-t194a

validating parameters

Check finished successfully
Done parsing command line

[bootburn]: [getListTargetsInRecovery(2847)] : Bus 001 Device 052: ID 0955:7019 NVidia Corp. 
sh: 1: cannot create /sys/module/usbcore/parameters/autosuspend: Permission denied
board is e3550b03-t194a

validating parameters

Check finished successfully
Done parsing command line

Bootburn Active
target validation is successfully completed
[bootburnTegra-A]: [formatTegraRCM(2884)] :  user = None does not have read/write permissions to /dev/bus/usb/001/052 
[bootburnTegra-A]: [formatTegraRCM(2885)] :  adding sudo access to tegra RCM calls 
[bootburnTegra-A]: [formatTegraRCM(2886)] :  To avoid using SUDO please add the following to your udev rules 
[bootburnTegra-A]: [formatTegraRCM(2887)] : 
[bootburnTegra-A]: [formatTegraRCM(2888)] :  SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="0955", MODE:="0666" 
[sudo] password for krisztian.holman:

No other password is requested and the nvidia user on the target clearly gets the password asked for the host user.

Could you please look into it and reproduce the issue?

Thank you very much in advance!

Dear @krisztian.holman,
We are working on fix for this issue. We will update you once it is available

1 Like

@ankitm4 @hfkou @krisztian.holman
The fix is available in SDK Manager 1.7.1. Thanks for reporting the issue.

1 Like