Unable to parse TensorRT Plan

Hi there,

I used dusty’s jetson inference example to create a TensorRT Plan from FCN-Alexnet-Cityscapes-HD caffe-network.
After that I tried to use it in the DriveWorks framework by:
dwDNN_initializeTensorRTFromFile(&m_networkHandle, m_context, fileName);
I ran the example on my Computer (not on the DrivePX) with the Gencode:
-gencode arch=compute_61,code=sm_61

Trying to read the TensorRT Plan on my computer I received this error:
TensorRT model file has wrong magic number. Please ensure that the model has been created by TensorRT_optimization tool in DriveWorks.

Of course this plan is not optimized for the DrivePX, but in my opinion I should be able to run it on my computer and load it into DriveWorks.
I have no idea why I get this error. I didn’t changed anything in the jetson inference example, so the plan should be correct.
The context is also working fine, I was able to initialize a bunch of other stuff.
Does anyone have an idea?

Thanks for your help and time!

Best regards
Mader

Dear madergona,
Please check the note in API. The model file has to be created using TensorRT_optimization tool to use in Driveworks.