Unable to permanently turn off autosuspend for a USB device connected to a Xavier NX

I’m trying to permanently turn off autosuspend for a camera connected to the Jetson via USB. I’ve successfully turned if off manually by doing:

$ echo 'on' | sudo tee /sys/bus/usb/devices/usb2/2-3/2-3.3/2-3.3.2/power/control
on

$ cat /sys/bus/usb/devices/usb2/2-3/2-3.3/2-3.3.2/power/control
on

Following the instructions here (Fixing USB Autosuspend), I added a usb-power.rules file.

$ cat /etc/udev/rules.d/usb-power.rules

# e-cons Systems See3CAM - USB3 Camera
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="2560", ATTR{idProduct}=="c154", TEST=="power/control", ATTR{power/control}="on"

Unfortunately, every time I reboot, the power/control goes back to auto:

$ cat /sys/bus/usb/devices/usb2/2-3/2-3.3/2-3.3.2/power/control
auto

I’m pretty sure I’m using the correct path to the USB.

$ cat /sys/bus/usb/devices/usb2/2-3/2-3.3/2-3.3.2/idVendor
2560

$ cat /sys/bus/usb/devices/usb2/2-3/2-3.3/2-3.3.2/idProduct
c154

I also tried changing

ATTR{power/control}=“on”

to

ATTR{power/control}:=“on”

Any idea what I’m doing wrong or how to “fix” this?

Thanks,

Tad Doxsee

Hi,

Maybe you can try to use other tools like rc local to overwrite the status.

You might also try to append this at the end of the “APPEND” key/value entry of “/boot/extlinux/extlinux.conf” (which would disable autosuspend on all USB rather than just the one device):
usbcore.autosuspend=-1

Then, after reboot, verify you see this at the end of parameters from “cat /proc/cmdline” (you can have other autosuspend entries, and the kernel will use the last occurrence).

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.