Unable to profile application

Today suddenly the nvvp refuses to work with a dialog saying Profiling failed
Unable to profile application
org.eclipse.core.runtime.CoreException: Reference to undefined variable EPREFIX
This happens to every program I tried.

It was working correctly yesterday. But suddenly this error appears now.
This is Gentoo linux with 3.2.14 kernel, Cuda 5.0, 64bit.
Anybody has some clue what went wrong?
Thanks in advance!

This is most likely some ebuild leaving crap in /etc/env.d and nvvp being lame at expanding environment vars…

Do the following:

grep -r EPREFIX /etc/env.d/

Say it finds /etc/env.d/50gconf…
…CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf"

…in any case goal is to eliminate EPREFIX from environment as it is an ebuild var in the 1st place and usually it should be equal to /.

So in this case this line would become:
CONFIG_PROTECT_MASK="/etc/gconf"

Save the modified /etc/env.d/50gconf

env-update
source /etc/profile
nvvp

…enjoy

It will work out of the box after next log in.

Can you try exiting the profiler and renaming the folder ~/nvvp_workspace to some other name? This is the folder where all the settings are kept so Visual Profiler should recreated it on the rerun.

Please, zip original folder (it does not contain any personal information) and mail it to cudatools@nvidia.com if this fixed the issue.

Hey @all,

i’m using gentoo and i have the same problems too.

changing
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf"
to
CONFIG_PROTECT_MASK="/etc/gconf"
did not help.

So i still can not profiling any cuda apps with my gentoo box.

are there some other things i can try?

Well is it still complaining about EPREFIX?
In terminal do:
env | grep EPREFIX

are there still any?

I also needed to make /opt/cuda/bin/nvvp look like:

#!/bin/sh
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/opt/cuda/lib64:/opt/cuda/lib"
UBUNTU_MENUPROXY=0
LIBOVERLAY_SCROLLBAR=0
/opt/cuda/libnvvp/nvvp

and /opt/cuda/libnvvp/nvvp.ini like:

-data
@user.home/nvvp_workspace
-vm
/etc/java-config-2/current-system-vm/jre/bin/java

Hey,

thanks for your reply!!! :)

nvvp was complaining that libcuinj is missing

There was no export in front of LD_LIBRARY_PATH … now it works fine.

Why do you need:

UBUNTU_MENUPROXY=0
LIBOVERLAY_SCROLLBAR=0

Thanks a lot!
David