Unable to put Jetson AGX DEvKit into Force Recovery mode

I have a Jetson AGX Xavier DevKit (32 GB) that is currently flashed with L4T v32.3.1. I want to upgrade it to the latest L4T version 32.5.1. I have an Ubuntu 18.04 host where I’ve downloaded the OS image, SDK components, tools etc. for L4T 32.5.1. However I am unable to boot the DevKit into Recovery mode.

I tried different combinations:

  1. Remove Power supply. Reconnect. Press and Hold Force Recovery Button → Press and Release Power Button → Release Force Recovery Button.

  2. Remove Power supply. Reconnect. Press and Hold Force Recovery Button → Press Power Button → Release Power and Force Recovery Buttons.

  3. Some other variants with Reset Button.

However SDK manager does not detect the NVIDIA DevKit. On the Host (Ubuntu 18.04), lsusb doesn’t show NVIDIA Corp. in the device list.

Attaching the Debug logs from SDK Manager - Any help is much appreciated.


SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_AGX_Xavier_2021-04-01_23-12-06.zip (103.1 KB)

Did you try after system power on normally, pressing and holding recovery button and then press reset button?

Hello @bobsaccamano

You can also set your device in recovery mode:

sudo reboot –-force forced-recovery

Before power feeding, press and hold recovery button.

I can confirm that this does not work.

Yes tried it. Doesnt work. SDK Manager does not detect the Xavier and lsusb does not show ‘NVIDIA Corp.’

Okay, it works now after I connect the Host to the USB-C Port opposite to the power plug. Is this documented anywhere? That would really have saved a lot of time…

Thank you all anyway for your answers.

Hi @bobsaccamano, please refer to the Jetson AGX Xavier Developer Kit User Guide: