Unable to remote desktop into Jetson Xavier? Tightvnc server broken?

After installing tightvncserver, xfce4 xfce4-goodies, and changing ~/.vnc/xstartup to:

xrdb $HOME/.Xresources
startxfce4 &

I start a vncserver on a port, and attempt to use a client on a different machine to go in.

The whole screen is gray. What am I missing here? Or is tightvncserver not really supported?
Is there an alternative if tightvncserver is not supposed to work? (Desktop Sharing built in does not work on Ubuntu 18.04.1 so I am looking for alternatives)

please see reference

Otherwise you may use qt&NoMachine based desktop sharing, e.g x2go

So that Desktop fix seemed to only work partly, but still has issues (I am unable to connect successfully with a VNC Client on Mac.

“Unable to connect to VNC Server using your chosen security setting. Either upgrade VNC Server to a more recent version from RealVNC, or select a weaker level of encryption.”

In the “Desktop Sharing Control Panel”…

I made sure to check boxes for “Allow other users to view your desktop” and “Allow other users to control your desktop”.

Under Security there are three options:
“You must confirm each access to this machine” (I originally kept the default checked, then left unchecked)
“Require user to enter this password” (I tried both keeping this checked, and unchecked)
“Automatically configure UPnP router to open and forward ports.” (I tried checking and unchecking this)

Nothing worked. When I attempt to connect, I do see in the Terminal where Vino was launched (using /usr/lib/vino/vino-server) that there was some attempt at connecting… but on my client I just see the same error at the top of this specific post. Questions/problems with that can be found in this thread:


I prefer not to use x2go, seems dated over a common VNC protocol that I am used to on other arm systems (e.g. Raspberry Pi, or any linux systems for that matter).

I tried tightvncserver as an alternative and configured xstartup with xfce, gnome, all to no avail.

Has anyone or does anyone know whether tightvncserver just doesn’t work and there is an alternative? Or are there xstartup contents I should be populating that makes it work? I’ve tried several combinations and all seem to fail with getting everything showing up after using a vnc client on mac.

I think it is saying you are attempting to use a weaker encryption level on software which deprecated this and considers rejection better than allowing insecure encryption. I don’t know if it is at the Jetson end, or if it is at the other computer’s end…one of them needs either have a stronger encryption added, or the other end have the stronger encryption removed (so they match). Removing could be as simple as editing something to tell it not to use strong encryption.

I think I get better performance with TightVNCServer (if it works), but for now the built in will have to do… though if anyone has ideas for configuration of TightVNCServer that actually works, please share.

The client needs to support the encryption protocols if it is desired to have encryption enabled. Otherwise you would need to disable encryption on the remote host like in this post: