Unable to run 08_video_dec_drm example

when running 08_video_dec_drm with --disable-video,
terminal outputs :

Set governor to performance before enabling profiler
Using VT number 3
[ERROR] (NvDrmRenderer.cpp:200) <renderer0> Couldn't open device: drm-nvdc
Error creating drm renderer
App run failed

after looking into NvDrmRenderer.cpp:200

 drm_fd = drmOpen(DRM_DEVICE_NAME, NULL);
  if (drm_fd == -1) {
    COMP_ERROR_MSG("Couldn't open device: " << DRM_DEVICE_NAME);
    goto error;
  }

so why open drm-nvdc failed?

before runnign thie demo, I’ve already ran the following command

nvstart-weston.sh
unset DISPLAY


and the /dev/dri/ folder has
by-path/ card0 renderD128

lsmod |grep “drm” gives:

nvidia_drm 61440 4
nvidia_modeset 1077248 2 nvidia_drm

desktop environment has already been disabled

Hi,
Do you disable default Ubuntu desktop? You would need to disable X11 before running the sample.

Hi,Dane.

We never disable the desktop on purpose, but when we reburn the kernel using the source code of L4T 34.1 from the download page, it seems desktop environment has already been disabled, and when we restart the device, we only see NVIDA logo, after logo showing up, no Ubuntu desktop environment comes out.

we also take [Jetson Linux API Reference: 08_video_dec_drm (Direct Rendering Manager) | NVIDIA Docs] as a reference.

Thanks for your help!

Hi,
We have confirmed this is an issue in 5.0.1 DP. We are debugging it. Will update.

Hi, Dane.

Any progress on this issue?

Hi,
We are working on it. It shall be fixed in next release.

Hi,
Any workaround at moment? We’re making a prototype that outputs result through HDMI without desktop environment.
But found no example as reference except DRM.

Is this an issue in 32.7.1 as well? The 08_video_dec_drm sample isn’t working on tx2 nx

DRM is still absent in 5.0.2. When it will be fixed?

Hi,
It shall work fine on Jetpack 5.0.2. Please try this sample:
Jetson Linux API Reference: 08_video_dec_drm (Direct Rendering Manager) | NVIDIA Docs

No, video_dec_drm does nor work:

cat /etc/nv_tegra_release

R35 (release), REVISION: 1.0, GCID: 31346300, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 25 18:41:45 UTC 2022

Display is working.

DISPLAY=:0 xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
1920x1080 60.00*+ 59.94 50.00

ls -l /dev/dri*
ls: cannot access ‘/dev/dri*’: No such file or directory

grep -i drm /var/log/Xorg.0.log
[ 27.222] (WW) NVIDIA: No DRM device: No direct render devices found.

There should be files like:
/sys/class/graphics/fb0/blank
/sys/class/graphics/fb1/blank

But nothing is there:
ls -l /sys/class/graphics/
only one file is shown:
lrwxrwxrwx 1 root root 0 Apr 21 12:54 fbcon → …/…/devices/virtual/graphics/fbcon

sudo systemctl stop gdm
sudo loginctl terminate-seat seat0

sudo ./video_dec_drm --disable-video
Set governor to performance before enabling profiler
Using VT number 2
[ERROR] (NvDrmRenderer.cpp:206) Couldn’t open device
Error creating drm renderer
App run failed

How to troubleshoot this?

Thank you

Hi,
There is one more step for Orin. Please try

Install nvidia-drm driver for Jetson Orin:
$ sudo modprobe nvidia-drm modeset=1

OK, this works, thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.