Unable to run OceanFFt sample in nsight


I’ve imported the OceanFFT sample into nsight; 2) the code will build but, I get an error about libcufft.so not found; see screen shot.

Do you have the path to the libcufft.so library included in your LD_LIBRARY_PATH environment variable?

On a standard 64-bit linux install of CUDA, something like this:

$ export LD_LIBRARY_PATH=/usr/local/cuda/lib64:$LD_LIBRARY_PATH

did that and no change. see new attachments

try just this:

export LD_LIBRARY_PATH=/usr/local/cuda/lib64

is there a libcufft.so.6.5 in /usr/local/cuda/lib64 on your machine?

I’m not sure but, here is the screen shot.

Apparently you didn’t accept the default /usr/local/cuda symlink during install.

so do this instead:

export LD_LIBRARY_PATH=/usr/local/cuda-6.5/lib64

by the way, the CUDA installer gives these instructions (to modify the LD_LIBRARY_PATH environment variable) after the CUDA installation is complete. You should not ignore those instructions.

I still get the same error. see attachment

To be clear, you need to do the following:

export LD_LIBRARY_PATH=/usr/local/cuda-6.5/lib64

then launch nsight eclipse edition from the same terminal window:


Its been done. see attachments

Besides, I use: /usr/local/cuda-6.5/libnsight/nsight to launch nsight eclipse.

thanx… got it fixed.

Yes, that is the wrong way to launch nsight.

You should just use: