Unable to run samples or new code on Quadro NVS295

I have a brand new desktop with the following configuration and no other software installed previously:

Windows XP Professional with SP3;

NVidia Quadro NVS 295 graphics card.

I installed the following software on this desktop in the order provided below:

Microsoft Visual C++ Express 2008;

Developer driver 263.06 from http://developer.nvidia.com/object/cuda_3_2_downloads.html;

CUDA toolkit 3.2.16 from http://developer.nvidia.com/object/cuda_3_2_downloads.html;

GPU computing SDK 3.2.16 from http://developer.nvidia.com/object/cuda_3_2_downloads.html.

Before doing anything else I ran deviceQuery.exe. This gave me the following result:

cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.

I then wrote a simple CUDA program to add two integers. The program compiled fine. However, when I ran the program it still gave me the same error.

Any clues as to why this is happening?

Can someone from NVidia please reply to this? I am leading a team that is considering CUDA for widespread deployment within my organisation and if we cannot get even the first installation working, it will mean a really unconvincing start for us.

Your card only support compute capability 1.1. But the toolkit support higher compute capability. So you should set the right compile parameter

Hi Huang

Can you elaborate what I need to do? My colleague, who sits next me has exactly the same set up and was able to run all the samples immediately after installing the SDK.

If you can point me to the correct compiler parameter to set, I can try again to make the samples work.

Appreciate your reply.

You mean the card, driver, toolkit, sdk and the develop IDE (VS 2008 express) are the same with your colleague ? I think you should try to install the driver and toolkit again. Make sure you have already uninstalled the driver before you install again.

Hi Huang

Yes, I and my colleague have exactly the same set up. In fact, he was the one to download all the software that I installed on my desktop after he had completed his installation.

I have tried uninstalling and re-installing everything several times but neither samples nor custom code are working.

I have also opened a support case with NVidia.

Your problem seems to be strange. I do not know the reason. I’m sorry