Unable to use deepstream-test1-app on NGC 6.0-devel container

You need to use nvidia X system to make deepstream app using sink type nveglglessink to work. i am not sure why add PCI into xorg.conf cause can not enter into system. it works on my side, but we use another series GPU P4.
Can you use RTSPStreaming for output view?

OK,I undestood,nvidia X system is the key of my issue。
Is it convenient for me to refer your xorg.conf file? Also I will try rtsp and a V100 GPU to see the difference.

Thank you,Sir!

xorg.conf (1.3 KB)

I checked my Jetson Xavier’s xorg.conf file, found this Option different
image

So I add this on my server.and the xorg.conf issue has been solved! I reboot the server and login normally!
Now,how do I know nvidia X system works?

Try to run deepstream app, which use nveglglessink type, like deepstream-app or test1 sample.

When CUDA is installed, the login issue occurs again. I continue to install CUDA and TRT, and then run sample in ssh,Deepstrem seems still not work


I found why PCI 23 into xorg.conf cause can not enter into system, I changed that to PCI 17:0:0 got a gdm login interface

Great. after login issue solved, deestream app still can not run?
noticed that, in the picture, having words TensorRT linked against cublas 11.6.3 but loaded cublas 11.5.4, which TensorT you are using?

I installed TensorRT 8.2 GA Update 1,with deb package.

You must install the following components:

  • Ubuntu 18.04
  • GStreamer 1.14.5
  • NVIDIA driver 470.63.01
  • CUDA 11.4
  • TensorRT 8.0.1


I used sudo apt remove --purge tensort command to uninstall TRT 8.2.

Sorry for the late.
You need to export display firstly if run from remote terminal.
export DISPLAY=:1 or 0 //xrandr to check if display export or not.
or run from desktop directly.

we meet the same problem,with using the image from NGC


Everything looks fine unless can’t login gdm3 …
Delete xorg.conf can login gdm3 but deepstream will have issue(I plugined the monitor device)

What do you mean can not login gdm3? system keep in loop when login? i remember you solved login loop issue?

I solved the login loop issue by delete xorg.conf file .But deepstream use the nvidia X system I don‘t know is that alright?
I notice when use the offical driver,that nvidia-smi Show nothing in Processes: Since I delete xorg.conffile and reboot ,the Process: show like the image above.

Yes. you need to use nvidia X system for deepstream use. do not delete this file, you need to solve the issue. try to see log under /var/log/Xorg.0.log /var/log/lightdm/ /var/log/gdm3/, depends on display manager used.

I notice when use the offical driver,that nvidia-smi Show nothing in Processes: Since I delete xorg.conf file and reboot ,the Process: show like the image above.

What do you mean nvidia-smi show nothing in process when use the offical driver? no X process running?
do restart display manager service. gdm3 or lightdm, depends on you used.
Did you install nvidia official driver?

Yes,I installed the offical NVIDIA drvier 470.63.01 and restart the gdm3,still have the
login loop issue.
Sir ,Since I’ve done a lot thing before.Avoiding that interference to you, I reinstalled my system now and will retry install drive. Got the log later!

Sir ,here is my log.
Xorg.0.log (27.5 KB)

Seems you are not loading nvidia driver, but nouveau driver.
i remember you use run file to install, did you disable nouveau driver firstly before install the nvidia display driver?

Yes,I change the blacklist-nouveau.conf with following ,use the offical driver and change BIOS display device with PCIE device
blacklist nouveau
options nouveau modeset=0