Unable to use the previously installed GPU driver

Dear all,

My PC has GPU GEFORCE 1050 and I used the GPU for a year on the Linux OS. Later, when I train deep learning for a month my PC mother board including GPU burn out. Then i have replaced similar mother board and GPU hardware with the previous. Every software and driver are not changed and only change the hardware. Now the previous installed GPU driver is not working. Please can you suggest me that why the first driver is unable to work? and can i install again or are there any other solutions?

please suggest me a direction.

Thank you.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

Dear Generix,

I run the command “nvidia-bug-report.sh” as a root and get the following result:

[root@localhost Tgeteye]# nvidia-bug-report.sh

nvidia-bug-report.sh will now collect information about your
system and create the file ‘nvidia-bug-report.log.gz’ in the current
directory. It may take several seconds to run. In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module. While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the ‘nvidia-bug-report.log.gz’ log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

Running nvidia-bug-report.sh…ls: cannot access /proc/driver/nvidia/./gpus/: No such file or directory

If the bug report script hangs after this point consider running with
–safe-mode and --extra-system-data command line arguments.


I think the GPU driver is not present and can i reinstall or are you suggest me other alternative?

With best regards,
nvidia-bug-report.log.gz (59.2 KB)

It creates a file named nvidia-bug-report.log.gz, please attach that.

Dear Generix,

Sorry for inconvenient, I attached the file “nvidia-bug-report.log.gz” with the previous post.

With best regards,

You have secure boot enabled so the driver can’t load since it isn’t signed. Please disable secure boot in bios. If that doesn’t resolve the issue, please create a new nvidia-bug-report.log.gz

Dear Generix,

Wow, It works now.
Thank you very much.

With best regards,