Unable to use VNC, rlogin on Sparkfun Jetbot

I assembled the Jetbot kit and the preflashed SD card that came with the kit. The OLED shows internet active wlan0 at My Network Magic shows the Nano at that address on my HP PC running Windows 10 up to date.
I cannot connect with my VNC client or using rlogin.
When I plug in the Ethernet cable the OLED shows a connection at Now my WiFi connection works fine as does the Ethernet connection at the two identified addresses. The minute I unplug the Ethernet cable the WiFi dies. I have many RPi’s working headless with WiFi. I am totally baffled with this issue.
As long as I have the Ethernet cable plugged in the robot moves fine using Wifi to log into Jupyter Labs. But that is not very useful.
Any suggestions would be appreciated. Sparkfun Technical support has been unable to assist me.

There is no much suggestions we can provided here, may other developers share their experiences.

I am in no way familiar with this, but I suspect that Network Manager (NM) is involved, and that the involvement is standard for an Ubuntu system. In most systems WiFi will only be used at certain times, and will be tied to the user currently logged in. Failing to log in to the GUI implies failing to enable the WiFi when this is the case.

If you want to use WiFi when nobody is logged in to the Ubuntu GUI you probably need to change the setup of WiFi to run even when nobody is logged in to that GUI. I do not use this, so someone else will need to suggest how to do so, but general documents on Ubuntu setting up WiFi to run without a login would apply to a Jetson as well as a desktop PC.

1 Like