Unable to use webrtc when I run runheadless.webrtc.sh in remote headless container

Is it possible to try the WebRTC client on another Windows or Linux PC?
It could be a network or firewall issue on host.
If you have Omniverse Launcher installed on host, try running Create natively and start the webrtc client to test too.

@Sheikh_Dawood I tried other PCs. As long as the WebRTC runs on a container, it is not possible to access it from anywhere, including the same PC (from outside the container: e.g., http://localhost:xxxx/streaming/webrtc-demo/?server=localhost), from other Macs, Linux or Windows PCs.

If WebRTC service runs from a native app rather than a container, I can access it from the same PC or another PC on the same network. There is no problem here.

I think the problem is something to do with the container. A firewall wouldn’t be an issue when trying to access the WebRTC of the container from the same PC; is this not correct?

Yes, I believe that is correct.

Are you running it this way?

docker run --name isaac-sim --entrypoint bash -it --gpus all -e "ACCEPT_EULA=Y" --rm --network=host \
    -v ~/docker/isaac-sim/cache/kit:/isaac-sim/kit/cache/Kit:rw \
    -v ~/docker/isaac-sim/cache/ov:/root/.cache/ov:rw \
    -v ~/docker/isaac-sim/cache/pip:/root/.cache/pip:rw \
    -v ~/docker/isaac-sim/cache/glcache:/root/.cache/nvidia/GLCache:rw \
    -v ~/docker/isaac-sim/cache/computecache:/root/.nv/ComputeCache:rw \
    -v ~/docker/isaac-sim/logs:/root/.nvidia-omniverse/logs:rw \
    -v ~/docker/isaac-sim/data:/root/.local/share/ov/data:rw \
    -v ~/docker/isaac-sim/documents:/root/Documents:rw \
    nvcr.io/nvidia/isaac-sim:2022.2.1 \
    ./isaac-sim.headless.webrtc.sh --allow-root

Then connect to for local PC?

If it is container specific issue, it could be a problem with docker. Can you try reinstall docker and NVIDIA container toolkit?

@Sheikh_Dawood , yes, I run like this or by running the runheadless.webrtc.sh script.

I have reinstalled the docker and Nvidia container toolkit, but it didn’t help.

Do not the error messages from my previous message give hints regarding the problem?

Any news on this?

I have the same issue here. Websocket and Native streaming work fine on my virtual machine hosted as an EC2 on AWS. But the webrtc doesn’t work at all.

I also noticed that you will remove the websocket in the future version. Could you please fix this issue?

Hi, I’m afraid we will only support Streaming Client over the Internet. Streaming Client and WebRTC should work well within the same network. WebSocket will be deprecated for our next release.

WebRTC now works in a container for me, in Isaac Sim 2023.1.0.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.