Unable to view CSI camera when a usb camera is plugged in

Hi,

I have a PureThermal2 board with a lepton 3.5 module and a Raspberry Pi v2.1 CSI camera. I am trying to access both of them in order to do a thermal overlay onto a captured video. However, when both cameras are plugged into the board, I am unable to view the Raspberry Pi Camera. But, I am still able to view the PureThermal feed. When I restart the nano and unplug the Purethermal I am able to see the captured video

Any help would be appreciated,
Alex

Hi,
We can reproduce the issue and is doing further check.

Have a try the lib from below.

https://devtalk.nvidia.com/default/topic/1059090/jetson-nano/usb-and-csi-cameras-capture-issues/post/5376683/#5376683

Hi,

I wanna buy Jetson Nano card for AI but, I have to learn Jetson Nano is compatible or not with any

MPI(Myocardial Perfusion Imaging) cameras.

Thank you.

Hi,

I’m using the same cameras as the OP and am facing a similar issue where the Raspberry Pi and Purethermal2/Lepton module can’t run concurrently. I’ve tried the suggested solution that ShaneCCC linked, but it was unsuccessful.

I noticed that the nano has trouble detecting the Raspberry Pi camera. If I plug in the RPi camera after the nano’s already on, it doesn’t show up in /dev/video. And if I plug in the camera before turning on the nano, it’ll be listed in /dev/video but then the entry doesn’t go away even if I pull the RPi camera out. Also, I’ve had several Purethermal boards stop responding after I tried running them after the RPi camera which I suspect is tied to this issue.

Any help with this issue would be greatly appreciated. Thanks in advance!

Hi Erika.Yu,
We don’t support hotplug of camera boards. you need to plug in before power-on.

Thanks for the quick reply DaneLLL.

I tried again with both cameras plugged in before powering on the nano but the issue is still the same.

As stated in my last post, I’ve already tried replacing with the files in https://devtalk.nvidia.com/default/topic/1059090/jetson-nano/usb-and-csi-cameras-capture-issues/post/5376683/#5376683

Can you confirm that these are the correct files to use? Or is there another way to resolve the issue?

Hi Erika.Yu,
Do you use r32.2.1? The prebuilt libs are for r28.2.1 and r32.1.

Hi DaneLLL,

I must’ve been using the wrong lib or a combination of that and not connecting it correctly because replacing the file fixed the issues this time. Thanks for the help!