Unable to view sgie labels

I am trying to use DS 3 with yolov3 as an object detector, tracker, and Secondary_CarColor (resnet 18) as a classifier on the tracked detections. I am currently able to detect and track objects using the yolo and the tracker. When I added the Secondary_CarColor as a secondary gie to the config I am not getting any errors but I am not able to see the color label. I tried both osd and extraction to a file.

How can I display/get the sgie label?

Thanks in advance.

Set appCtx[0]->show_bbox_text = TRUE; in deepstream_app_main.c before g_main_loop_new
and re-build deepstream-app

Tried to add this line and rebuild the deepstream-app but it still does not show the secondary label.

It should work.
Did you try the default config “source4_720p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt” ?

Hi amit.rozner

Have you managed to show the secondary label you want?
Is this still an issue to support?


No I have not managed to see or extract the secondary label using the above solutions.

Can you try to change “classifier-async-mode=0” ? Is it OK?

I had the same issue of not seeing sgie labels and realized that I need to enable the tracker.

how to enable tracker ??? im not able to view the labels set in the tracker probe .
Do we need to set classifier-async-mode=0 in the tracker config file ?

Hi h9945394143,

Please help to open a new topic if it’s still an issue to support?