Uncertain installation for CUDA 5.0

Hi CUDA developers,

I bought my new Macbook Pro 15 which comes with the GT650M. I like to do CUDA programming and just installed the CUDA development kit and driver.

CUDA Driver Version: 5.0.37
GPU Driver Version: 8.6.22 304.10.20f04

Everything runs smooth and except the following:

  1. I run deviceQuery and the last line… Passed is missing
  2. I run bandwidthTest and the last line… Passed is missing.

For 1 & 2, please refer to the attached document.

I notice that after compilation the resulting binaries will be placed under /Developer/NVIDIA/CUDA-5.0/samples/bin/darwin/release but not under /Developer/NVIDIA/CUDA-5.0/samples/C/bin/darwin/release.

Is this causing the issue for the missing Passed in both deviceQuery and bandwidthTest?

I am using Xcode 4.6 and the default complier is llvm-gcc-4.2, not gcc-4.2. I suspect this is related to the issue.

However, I run the particle executable and it is running fine.

Can you help confirm if my CUDA installation is done properly? Many thanks.

Regards,
Samuel

The compiled/source SDK programs of CUDA 5.0 doesn’t output a ‘PASSED’ for deviceQuery and bandwidthTest. You can check the source code for the SDK examples yourself and see. Sounds like your installation is just fine.

Hi vacaloca,

thanks very much. I checked that the installation is going ok. Just check the source code of deviceQuery and it does include “PASSED” in the end of the program.

It is just this site http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-mac-os-x/index.html is a bit misldeading.

Thanks and have a good day.