undefined symbol: __cudaPopCallConfiguration

I used cuda 9.0 and Pytorch 0.4 for using cuda in python with ubuntu 16.04.

I have some error like below when I used some Pytorch layer with CUDA function:

_roi_pooling.so: undefined symbol: __cudaPopCallConfiguration

What is this error, and how can I fix it?

I have the same problem, also on Ubuntu 16.04. I’m trying to build my own project with Cython and CUDA. The problem seems to occur not only with CUDA 9.0 but also 9.2, as well as 10.0 and 8.0. It first came up, when I tried building using c++11, (which CUDA 8.0 does not support) and installing CUDA 10.0. Since then I have removed all traces of CUDA from my system and re-installed it, but the problem still persists. I think it is likely a problem of not installing correctly or some path being not correctly specified.

Did anyone find a solution to this problem?

I had this same problem with Ubuntu 16.04, Pytorch 0.4 and CUDA 9.0. Will report here when I found a solution.

I solved this issue by using CUDA 8.0 + Pytorch 0.4.0.