unexpected zeroes when using reshape


I am seeing the following error at compilation time:

PGF90-F-0000-Internal compiler error. cf_data_init: unexpected zeroes 0 (/home/kaw2e11/ONETEP_GPU/src/geometry_optimiser_mod.F90: 511)
make[1]: *** [geometry_optimiser_mod.o] Error 2

Where the offending code is:

integer, parameter, dimension(1:3,1:3) :: &

Any suggestions?



I’m sure PGI will weigh in, but the usual advice is that Internal Compiler Errors are problems with the compiler itself and should be reported to PGI Customer Service (trs@pgroup.com). Usually only the engineers can figure out what’s causing them.

When I get them, I like to send the smallest reproducer I can make.

Easier said than done in this case. I have tried to create something equivalent but it compiles without issue.

I was hoping it was a known issue with the reshape intrinsic to be honest.


I just tried to compile with 11.9 and saw the same issue there.
This is the first time I have tried to compile the code on this particular machine, the same code compiles fine with 11.9 on my desktop.

I am checking a few things out and will update if I find anything.

edit: This problem is still present and seems to be specific to the combination of the specific machine, accelerator compiler flags and a compilation of the entire program source.
Compilation of the problem file alone has no problem.
Compilation without accelerator flags is fine.
Identical compilation on my desktop is fine.
The problem occurs with both 11.9 and 12.2.

However, I have bypassed the problem by only using the accelerator flags on the routines that require them. This is a cleaner solution anyway.

I will attempt to recreate the problem with a smaller sample code and then email it to PGI.