Unknown filesystems/partition table for SD Card (missing apt packages?)

I don’t know where else to ask this question.

I have recently gotten a new laptop and I am unable to read the SD card with it.

I can see the partition table layout (and mount partitions on my old laptop)
listed|690x468

both laptops are running Linux Mint 20 x64.

I suspect that I have installed packages on my old laptop that mean I can see/read the filesystems that I need to install on my new laptop. please help!

edit2add
I thought perhaps it was somehow connected to the SDK Manager so downloaded/installed it but still cannot view/mount the partitions. :(

Regardless of type of filesystem and regardless of partition types, any memory using either the older BIOS scheme or UEFI schema should show the partitions. What do you see if you use the following to find information on the SD card? I am pretending the card is “/dev/mmcblk1”, but substitute for your case (e.g., if it shows up as “/dev/sdb”, then use that…you can monitor “dmesg --follow”, and view what shows up as you insert the card):

fdisk -l /dev/mmcblk1
sudo gdisk -l /dev/mmcblk1

Do those commands work on the laptop which sees the partitions in your GUI app? Do those same commands show up differently on the other laptop?

hello wodgey,

please also check https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#write for getting started with Jetson Nano Developer Kit.
thanks

1 Like

I’ve performed the same 3 operations on both laptops. dmesg --follow whilst instering the sdcard, then fdisk -l and gdisk -l

dmesg gives a long list of errors on the new laptop, so I have pasted the entirety of all 6 outputs to pastebin

format
New Laptop

dmesg --follow

fdisk -l

gdisk -l

Old Laptop

dmesg --follow

fdisk -l

gdisk -l

Because I see this output we know it is a UEFI style partition setup:
Found valid GPT with protective MBR; using GPT.

This implies you can avoid using fdisk and look only at gdisk when using those tools.

Your new laptop had a serious kernel error which the old laptop did not have. An excerpt from the new laptop:

[  302.616767] irq 18: nobody cared (try booting with the "irqpoll" option)
[  302.616771] CPU: 5 PID: 0 Comm: swapper/5 Tainted: P           O      5.8.0-33-generic #36~20.04.1-Ubuntu
[  302.616771] Hardware name: HP HP Pavilion Gaming Laptop 17-cd1xxx/8745, BIOS F.13 07/16/2020
[  302.616772] Call Trace:
[  302.616773]  <IRQ>
[  302.616777]  dump_stack+0x74/0x9a
[  302.616780]  __report_bad_irq+0x3a/0xaf
[  302.616781]  note_interrupt.cold+0xb/0x61
[  302.616782]  handle_irq_event_percpu+0x73/0x80
[  302.616783]  handle_irq_event+0x3b/0x5a
[  302.616784]  handle_fasteoi_irq+0x9c/0x150
[  302.616786]  asm_call_irq_on_stack+0xf/0x20
[  302.616786]  </IRQ>
[  302.616788]  common_interrupt+0xc1/0x150
[  302.616789]  asm_common_interrupt+0x1e/0x40
[  302.616791] RIP: 0010:poll_idle+0x69/0xbb
...
[  302.616814] Disabling IRQ #18
[  311.566988] alcor_sdmmc alcor_sdmmc.0: Timeout waiting for hardware interrupt.
[  311.572507] alcor_sdmmc alcor_sdmmc.0: alcor_reset: timeout
[  311.572551] alcor_sdmmc alcor_sdmmc.0: error -123 requesting status
[  311.722481] mmc0: tried to HW reset card, got error -123
[  311.722482] mmcblk0: recovery failed!
[  311.722490] blk_update_request: I/O error, dev mmcblk0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[  311.722492] Buffer I/O error on dev mmcblk0, logical block 0, async page read
[  311.722557] alcor_sdmmc alcor_sdmmc.0: error -123 requesting status
[  311.722558] mmcblk0: recovery failed!

From what I can tell there are hardware failures on the new laptop. The reason the SD card could not succeed was probably not due to the SD card itself since it works on the old laptop. Regardless, there may be some filesystem inconsistencies on the SD due to failures while testing.

There are a number of reasons why this could fail on the new laptop. One is simply due to lack of correct (and updated) drivers or firmware. I have no way to speculate on specific details, but you might describe on the new laptop how the SD card is plugged in. For example, through a HUB or directly to an integrated reader. If you have an external reader using USB, then you might want to describe this as well. Also, is it correct that the new laptop is using Ubuntu 18.04?

It’s Mint 20, which is based on ubuntu.

the Reader is an integrated type, made by Alcor (model 6625) for which the drivers are integrated into kernel 5.6 upwards (I have installed kernel 5.8)

I had already come to the conclusion that it was kernel related, rather than hardware, or rather I am sure that the hardware is working because when I dual boot into Windows, I get 14 popups saying “this drive needs formatting before it can be used” (or whatever the wording is, but I am sure you know the popup I mean) which means that Windows can see the partition table but obv. can’t read *nix filesystems.

In my dmesg posting, I count 14 instances of mmcblk0: recovery failed! too

I’ve had to reinstall windows on my new laptop due to an issue with cyberpunk 2077 and still need to repair grub before I can boot into Linux but before I did so, I flashed firmware vers20 onto my new laptop (I was running vers13 that shipped with the machine)
Maybe that will help, I will report back

edit 2add
I get the same problem with my 32Gb sdcard too. So I know it isn;t due to my 128Gb card not being supportted/read due to its size

Yes, you are correct. I said “hardware”, but what I should have said is that “the hardware does not work, and likely this is due to driver or firmware missing” (and driver is part of the kernel).

You are also correct that Windows has no understanding of the filesystems on the SD card. This is not a problem, and if you format the card, then you’ll end up erasing part of your Jetson’s operating system. Just tell it to not format.

Failure to recover can be either a failure of the hardware to read/write correctly, or it can be due to a very badly mangled filesystem. Let us know what happens after the laptop repairs are made.

1 Like

yes, thank you. I am aware of the limitations regarding windows and ext2/3/4 (edit2add - Linux filesystems in general) file systems and had no intention of formatting the partitions. It was just an indication that the hardware is working under windows so the issue was with Nix.

I have since been doing a lot more reading and I am not the only person having difficulties with this particular model of card reader.

https://linux-hardware.org/index.php?id=pci:1aea-6625-103c-8478years

It does mean that I will need to do all my flashing/chrooting from my old (lenovo w520) laptop rather than my shiny new one :(
Well, until i learn how to recompile my kernel, that is. I have only ever tried this once and it didn;t work well (approx 20 years ago, on slackware 10)
your input has been appreciated though.