!!! Unknown header type 7f

background: Endpoint is xilinx v7960t, rc is tx2.They communicate through the pcie
question:What does that mean?I have seen the same problem but not solved

nvidia@tegra-ubuntu:~$ lspci -vv
00:01.0 PCI bridge: NVIDIA Corporation Device 10e5 (rev a1) (prog-if 00 [Normal decode])
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 388
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: 50100000-502fffff
Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Kernel driver in use: pcieport

01:00.0 Serial controller: Xilinx Corporation Device 7024 (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel driver in use: xdma
Kernel modules: xdma

It looks like the device has come up but has gone off the bus (or) fallen off the bus.
This kind of stuff is possible if the endpoint device initially pulls the clkreq down and then releases it later on. Can you please share the software release version you are using?
If the issue is because of this, please add “nvidia,disable-clock-request” to the respective PCIe root port (the ones starting in the format “pci@1,0” / “pcie@2,0” / “pci@3,0”

ubuntu version: 16.04
kernel version: 4.4.38-tegra

by the way, how can i add “nvidia,disable-clock-request” to the respective PCIe root port? could you give me some command or coding?

You can either get the source code and find the device tree file “tegra186-soc-base.dtsi” and in that fine the nodes “pci@1,0” / “pcie@2,0” / “pci@3,0” and just add the entry “nvidia,disable-clock-request”.
Just to make sure that this entry is indeed present, you can go to “/proc/device-tree/pcie-controller@10003000/pci@1,0” on target and check if the entry is present or not.

Does this affect the transmission speed of the pcie

Not at all.

thank you very much