unknown numeric_limits<double>::lowest() in PGI 16.7

Hi,

trying to compile

const double low = std::numeric_limits<double>::lowest();

with PGI 16.7 gives the following error message:

error: class "std::numeric_limits<double>" has
          no member "lowest"
    const double low = std::numeric_limits<double>::lowest();

The other member functions such as max(), min() etc. seem to compile just fine.

Thanks,
LS

Probably another issue with C++11. Get the right g++ environment, install
everything again, and you should be okay.

dave

OK, got it. I need to put my desired GCC version in the PATH and then reinstall PGI. Do you know whether version 5.2 is OK even though I think officially you only support up to 5.1?

Thanks,
LS

5.2 will not be supported until 16.10.

dave