Unknown sequence number while appending request

(isaac-sim-2023.1.1) bong@bong:~/.local/share/ov/pkg/PointCloudGenerator$ /home/bong/anaconda3/envs/isaac-sim-2023.1.1/bin/python /home/bong/.local/share/ov/pkg/PointCloudGenerator/main.py
Starting kit application with the following args:  ['/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.kit/omni/isaac/kit/simulation_app.py', '/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/apps/omni.isaac.sim.python.kit', '--/app/tokens/exe-path=/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit', '--/persistent/app/viewport/displayOptions=3094', '--/rtx/materialDb/syncLoads=True', '--/rtx/hydra/materialSyncLoads=True', '--/omni.kit.plugin/syncUsdLoads=True', '--/app/renderer/resolution/width=1280', '--/app/renderer/resolution/height=720', '--/app/window/width=1440', '--/app/window/height=900', '--/renderer/multiGpu/enabled=True', '--/app/fastShutdown=True', '--ext-folder', '/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/exts', '--ext-folder', '/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/apps', '--/physics/cudaDevice=0', '--portable']
Passing the following args to the base kit application:  []
[Info] [carb] Logging to file: /home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/logs/Kit/Isaac-Sim/2023.1/kit_20240425_145031.log
2024-04-25 05:50:31 [0ms] [Warning] [omni.kit.app.plugin] No crash reporter present, dumps uploading isn't available.
[0.059s] [ext: omni.kit.async_engine-0.0.0] startup
[0.695s] [ext: omni.activity.core-1.0.1] startup
[0.698s] [ext: omni.assets.plugins-0.0.0] startup
[0.701s] [ext: omni.stats-0.0.0] startup
[0.703s] [ext: omni.client-1.0.1] startup
[0.718s] [ext: omni.activity.profiler-1.0.2] startup
[0.721s] [ext: omni.gpu_foundation-0.0.0] startup
[0.743s] [ext: omni.rtx.shadercache.vulkan-1.0.0] startup
[0.745s] [ext: carb.windowing.plugins-1.0.0] startup
[0.754s] [ext: omni.kit.renderer.init-0.0.0] startup

|---------------------------------------------------------------------------------------------|
| Driver Version: 535.171.04    | Graphics API: Vulkan
|=============================================================================================|
| GPU | Name                             | Active | LDA | GPU Memory | Vendor-ID | LUID       |
|     |                                  |        |     |            | Device-ID | UUID       |
|     |                                  |        |     |            | Bus-ID    |            |
|---------------------------------------------------------------------------------------------|
| 0   | NVIDIA GeForce RTX 3070 Ti       | Yes: 0 |     | 8438    MB | 10de      | 0          |
|     |                                  |        |     |            | 2482      | a15bf82d.. |
|     |                                  |        |     |            | 1         |            |
|=============================================================================================|
| OS: 20.04.6 LTS (Focal Fossa) ubuntu, Version: 20.04.6, Kernel: 5.15.0-102-generic
| XServer Vendor: The X.Org Foundation, XServer Version: 12013000 (1.20.13.0)
| Processor: 11th Gen Intel(R) Core(TM) i7-11700F @ 2.50GHz | Cores: 8 | Logical: 16
|---------------------------------------------------------------------------------------------|
| Total Memory (MB): 96436 | Free Memory: 92578
| Total Page/Swap (MB): 2047 | Free Page/Swap: 2047
|---------------------------------------------------------------------------------------------|
[1.295s] [ext: omni.kit.pipapi-0.0.0] startup
[1.297s] [ext: omni.kit.pip_archive-0.0.0] startup
[1.297s] [ext: omni.pip.compute-1.2.0] startup
[1.298s] [ext: omni.pip.cloud-1.0.1] startup
[1.299s] [ext: omni.isaac.core_archive-2.2.1] startup
[1.299s] [ext: omni.pip.torch-2_0_1-2.0.2] startup
[1.334s] [ext: omni.kit.telemetry-0.5.0] startup
[xcb] Unknown sequence number while appending request
[xcb] You called XInitThreads, this is not your fault
[xcb] Aborting, sorry about that.
[xcb] Extra reply data still left in queue
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
Fatal Python error: Segmentation fault

Thread 0x00007f6955b140c0 (most recent call first):
  File "<frozen importlib._bootstrap>", line 241 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 1176 in create_module
  File "<frozen importlib._bootstrap>", line 571 in module_from_spec
  File "<frozen importlib._bootstrap>", line 674 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1006 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1027 in _find_and_load
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/exts/omni.kit.telemetry/omni/kit/telemetry/__init__.py", line 7 in <module>
  File "<frozen importlib._bootstrap>", line 241 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 883 in exec_module
  File "<frozen importlib._bootstrap>", line 688 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1006 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1027 in _find_and_load
  File "<frozen importlib._bootstrap>", line 1050 in _gcd_import
  File "/home/bong/anaconda3/envs/isaac-sim-2023.1.1/lib/python3.10/importlib/__init__.py", line 126 in import_module
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/custom_importer.py", line 76 in import_module
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/_internal.py", line 94 in _import_public
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/_internal.py", line 187 in _custom_importer
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/_internal.py", line 211 in startup
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/kit/kernel/py/omni/ext/_impl/_internal.py", line 328 in startup_extension
  File "PythonExtension.cpp::startup()", line 2 in <module>
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.kit/omni/isaac/kit/simulation_app.py", line 304 in _start_app
  File "/home/bong/.local/share/ov/pkg/isaac_sim-2023.1.1/exts/omni.isaac.kit/omni/isaac/kit/simulation_app.py", line 192 in __init__
  File "/home/bong/.local/share/ov/pkg/PointCloudGenerator/main.py", line 5 in <module>

Extension modules: numpy.core._multiarray_umath, numpy.core._multiarray_tests, numpy.linalg._umath_linalg, numpy.fft._pocketfft_internal, numpy.random._common, numpy.random.bit_generator, numpy.random._bounded_integers, numpy.random._mt19937, numpy.random.mtrand, numpy.random._philox, numpy.random._pcg64, numpy.random._sfc64, numpy.random._generator, scipy._lib._ccallback_c, scipy.sparse._sparsetools, _csparsetools, scipy.sparse._csparsetools, scipy.sparse.linalg._isolve._iterative, scipy.linalg._fblas, scipy.linalg._flapack, scipy.linalg._cythonized_array_utils, scipy.linalg._flinalg, scipy.linalg._solve_toeplitz, scipy.linalg._matfuncs_sqrtm_triu, scipy.linalg.cython_lapack, scipy.linalg.cython_blas, scipy.linalg._matfuncs_expm, scipy.linalg._decomp_update, scipy.sparse.linalg._dsolve._superlu, scipy.sparse.linalg._eigen.arpack._arpack, scipy.sparse.csgraph._tools, scipy.sparse.csgraph._shortest_path, scipy.sparse.csgraph._traversal, scipy.sparse.csgraph._min_spanning_tree, scipy.sparse.csgraph._flow, scipy.sparse.csgraph._matching, scipy.sparse.csgraph._reordering, scipy.spatial._ckdtree, scipy._lib.messagestream, scipy.spatial._qhull, scipy.spatial._voronoi, scipy.spatial._distance_wrap, scipy.spatial._hausdorff, scipy.special._ufuncs_cxx, scipy.special._ufuncs, scipy.special._specfun, scipy.special._comb, scipy.special._ellip_harm_2, scipy.spatial.transform._rotation, psutil._psutil_linux, psutil._psutil_posix (total: 51)
Segmentation fault (core dumped)

Hi, After installing open3d,
(isaacsim) $ conda install -c open3d-admin -c conda-forge open3d
I got an error above.
I used to install Open3d on other workstations/conda environments. However, this is the first time I have had this kind of error.

Any advice will be helpful for me.
Thanks.

  • open3d uninstallation easily resolves this issue.
    However, I want to know the primary reason since I worked with open3d for a long time, having many related files.

It seems like one of the below causes the problem.

The following packages will be SUPERSEDED by a higher-priority channel:

  certifi            conda-forge/noarch::certifi-2024.2.2-~ --> pkgs/main/linux-64::certifi-2024.2.2-py310h06a4308_0 

  ffmpeg             conda-forge::ffmpeg-6.1.1-gpl_hf3b701~ --> pkgs/main::ffmpeg-4.2.2-h20bf706_0 

  gmp                     conda-forge::gmp-6.3.0-h59595ed_1 --> pkgs/main::gmp-6.2.1-h295c915_3 

  gnutls               conda-forge::gnutls-3.7.9-hb077bed_0 --> pkgs/main::gnutls-3.6.15-he1e5248_0 

  libvpx              conda-forge::libvpx-1.13.1-h59595ed_0 --> pkgs/main::libvpx-1.7.0-h439df22_0 

  nettle               conda-forge::nettle-3.9.1-h7ab15ed_0 --> pkgs/main::nettle-3.7.3-hbbd107a_1 

  openh264           conda-forge::openh264-2.4.0-h59595ed_0 --> pkgs/main::openh264-2.1.1-h4ff587b_0 

  x264               conda-forge::x264-1!164.3095-h166bdaf~ --> pkgs/main::x264-1!157.20191217-h7b6447c_0