Unplayable graphics after update

Hi there,

I’ve got an MSI GE70 2PE Apache Pro with Manjaro XFCE. In the past I’ve been playing World of Warcraft 2.4.3 under wine with no issues (about early 2018) with both, nvidia-xrun and bumblebee. After some months without trying, I’m experiencing now about 10fps performance and mouse laggish.

I noticed this behaviour in early September and I’ve been trying different distros (Ubuntu Mate, Manjaro KDE) with the same result. In case it was a wine problem, I tried native Minecraft and the performance is nearly unplayable even on it… I’m quite deranged already and I will pleasantly provide any information/output needed.

Thanks in advance…

Is this only a problem when using wine, i.e. do native games/demos run fine?
Might be that wine is somehow falling back to software rendering. Please run a game in windowed mode, then run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

Okay so, it is not a problem when using Wine only. Having tested in native Minecraft results in a slow rendering of textures, taking into account the hardware…

Attached the bug report.
nvidia-bug-report.log.gz (1.02 MB)

The problem is that your gpu is locked to 33MHz, which is…nothing.
Did you do a bios upgrade prior to upgrading? Did you already try to downgrade the driver to nvidia-390 or even nvidia-340?
Maybe this is related to suspending the gpu, please uninstall bbswitch so the gpu stays on after boot and test.

After removing bbswitch and rebooting, the problem persists (attached new bug report). Both 340 and 390 drivers have same performance problem in my machine. I haven’t done any bios upgrade since I moved to Linux three years ago.
nvidia-bug-report.log.gz (1.01 MB)

Seems to be a specific problem of the notebook model:
https://devtalk.nvidia.com/default/topic/831369/?comment=4530202
Though it’s very odd why you’ve been running into it just now after it had been working for several years.
Things to try:
Remove AC, remove battery, press and hold the power button for 30sec. Connect AC, boot and check.
Or see if the tip from the thread works, booting on battery only and check.
See if adding/removing the kernel parameter
nvidia-drm.modeset=1
changes anything.

Have tried everything with no positive results…

If you use PRIME instead of bumblebee, does the gpu also stay at 33MHz?

It does. I’ve tried this in Manjaro XFCE, Manjaro KDE and Ubuntu Mate.

Ok, then I think it’s only left to install Windows to rule out a general hardware fault.