Unpredictable behavior of Jetson Nano board on different versions of JetPack with flashed IMX477 drivers

I have some strange trouble with Jetson Nano B01 4Gb. First of all i flashed JetPack 4.5 to board via sd-card image and worked during some time. Then its needed to me to install drivers IMX477 to get support of HQ RPI cameras. I installed drivers via 2 different methods but it was both unsuccessful. Board couldnt see camera device in /dev/ .
Later i tried to boot other sd-card image that worked in other Jetson Nano board before with JetPack4.4. This image built with drivers IMX477 and used earlier on other Jetson Nano board B01 4Gb, but with Jetpack 4.4. When i tried to boot this image with JetPack 4.4 on Jetson Nano after using on board JetPack 4.5, i had got rebooting system on nvidia logo. Then i tried to load first image with my Jetpack 4.5 but already it was unsuccessful (also rebooting system).
Finally, i tried to do all this steps on new purchased Nvidia Jetson Nano and i got the same result.
How i can resolve this trouble and what the main reason of unpredictable behavior?

hello ira.larina.98,

there should be Jetson Device-tree overlay for Camera IMX477 RBPCV3.
please download the latest JetPack release, (i.e. JetPack-4.6), and you should refer to Using the Jetson-IO Tool for the device registration.