Unsuccessful Jetson Orin NX Jetpack 6 Flash

I have a Jetson Orin NX from Yahboom. I am trying to upgrade the jetpack version to 6. I have not suceeded once, I have tried to flash it several times in Ubuntu 20.04 VMs and also natively running Ubuntu 20.04 machines. No luck. The Jetson will enter Force Recovery Mode and it is connected to the host machine. When I choose the runtime setting, the Nvidia screen will pop up for a couple seconds and then go away, not even letting me set anything up. This is what it displays on the screen:

EFI stub: Booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
EFI stub: Exiting boot services…

And then a blank screen. After the SDK Manager launches its steps fro downloading components, it isnt able to connect via IP address. And although the system image was flashed successfully, when I boot the machine again, nothing happens.
SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-03-30_07-26-18.zip (128.8 KB)

Please share the full serial console log from your jetson and also the full host side log from same flash.

Also, is this device still be able to flash with jetpack5 now or not?

I am not quite sure how to retrieve those logs for you, I have attached the exported zip file from sdk manager, is this not what you’re looking for?

And i have not tried to flash jetpack 5 again so i am not sure.

  1. If this is your first day using a jetson, try Jetpack5 first. Jetpack6 is still a developer preview version.

  2. I am actually not sure about whether you are using a NV developer kit or a custom board from other vendor. If this is from other vendor, then sdkmanager may not be able to flash it. Please check with the vendor for customized software.

  3. Flash a board is something between host PC and Jetson. You only shared the log from host PC, but didn’t have the log from Jetson. So, yes, the log you shared is just half info I need.
    Device log could be retrieved by such method.
    https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

I did buy the Jetson board from Yahboom, however, from other forums I have concluded that it isnt different from the NV developer kit. I also do not have access to the ttl serial cabel. The jetson had 5.1.1 already installed onto it, I am trying to upgrade to 6.0 to run ubuntu 22.04. Is there anything else I could do? I also was not clear on whether or not I have to prepare the NVME SSD in advance before flashing the Jetson. The SSD I initially plugged in had Ubuntu 20.04 on it with some partitions, I am not sure what is on it anymore after the multiple flashes that I have tried.

UPDATE: I was able to flash jetpack 6 and have ubuntu 22.04 running but some stuff is messed up, like there is no wifi setting anymore, and when i tried to run docker it would not run due to this error:

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.

I fixed it by running these commands:

sudo update-alternatives --set iptables /usr/sbin/iptables-legacy
sudo update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy

Also when i boot up the jetson it goes black, a bunch of text starts to appear in a shell and then it shows a blank nvidia logo screen then finally boots into 22.04.

Hi,

If the board is already got flashed, then please file a new topic.

BTW, to analyze your issue, you still need to buy the usb-ttl cable so that you can know t he status of the board.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.