Update breaks software rendering in VNC.

We run an HPC cluster, some of our nodes have CUDA capable cards many do not.

We recently updated our RedHat install. This updated MESA and a few other libraries. We then install the NVIDIA package over top. To keep linking from breaking we need libcuda.so on all our machines. This also replaces libGL.so with the nvidia one.

What broke in this update we cannot figure out is software GL rendering. We don’t run actual X Servers. But we do allow users to run VNC sessions. Before the update this worked fine. glxinfo showed that GL vendor was NVIDIA, but now on the update all the libraries look the same, but anything using GL fails.

Extension GLX not found

We can fix it if we uninstall the NVIDIA package but then anything linked against libcuda breaks, so we are copying that back onto the nodes.

What’s odd is that this all worked for a long time before. If anyone has any ideas let us know. Our NVIDIA package version is 340.64 mesa version after the update is mesa-libGL-10.1.2-2.el6.x86_64

Thanks. Again we don’t run X its for CUDA only, and we need software GL to work, but also want things linked against libcuda to work and this worked for a few years until recently.